forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-gfx/cura: version bump to 4.6.1
Closes: https://bugs.gentoo.org/710930 Closes: https://bugs.gentoo.org/718960 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Perlov <[email protected]> Closes: gentoo#15908 Signed-off-by: Alexey Shvetsov <[email protected]>
- Loading branch information
Showing
3 changed files
with
88 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{6,7} ) | ||
inherit cmake desktop python-single-r1 xdg | ||
|
||
MY_PN=Cura | ||
|
||
DESCRIPTION="A 3D model slicing application for 3D printing" | ||
HOMEPAGE="https://github.com/Ultimaker/Cura" | ||
SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="LGPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+usb zeroconf" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
BDEPEND="sys-devel/gettext" | ||
RDEPEND="${PYTHON_DEPS} | ||
>=dev-libs/libcharon-${PV:0:3}[${PYTHON_SINGLE_USEDEP}] | ||
>=dev-libs/libsavitar-${PV:0:3}:=[python,${PYTHON_SINGLE_USEDEP}] | ||
>=dev-python/uranium-${PV:0:3}[${PYTHON_SINGLE_USEDEP}] | ||
>=media-gfx/curaengine-${PV:0:3} | ||
>=media-gfx/fdm-materials-${PV:0:3} | ||
$(python_gen_cond_dep ' | ||
dev-python/requests[${PYTHON_MULTI_USEDEP}] | ||
dev-python/sentry-sdk[${PYTHON_MULTI_USEDEP}] | ||
usb? ( dev-python/pyserial[${PYTHON_MULTI_USEDEP}] ) | ||
zeroconf? ( dev-python/zeroconf[${PYTHON_MULTI_USEDEP}] ) | ||
')" | ||
DEPEND="${RDEPEND}" | ||
|
||
DOCS=( README.md ) | ||
PATCHES=( "${FILESDIR}/${PN}-4.6.1-fix-install-paths.patch" ) | ||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
src_prepare() { | ||
sed -i "s/set(CURA_VERSION \"master\"/set(CURA_VERSION \"${PV}\"/" CMakeLists.txt || die | ||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" | ||
) | ||
cmake_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake_src_install | ||
doicon icons/*.png | ||
python_optimize "${D}${get_libdir}" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
--- Cura-4.5.0-orig/CMakeLists.txt 2020-03-01 16:32:23.380956083 +0200 | ||
+++ Cura-4.5.0/CMakeLists.txt 2020-02-25 17:16:45.000000000 +0200 | ||
@@ -48,6 +48,15 @@ | ||
find_package(Python3 REQUIRED COMPONENTS Interpreter Development) | ||
endif() | ||
|
||
+if(NOT PYTHON_SITE_PACKAGES_DIR) | ||
+ if(APPLE OR WIN32) | ||
+ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages | ||
+ CACHE STRING "Directory to install Python bindings to") | ||
+ else() | ||
+ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages | ||
+ CACHE STRING "Directory to install Python bindings to") | ||
+ endif() | ||
+endif() | ||
|
||
if(NOT ${URANIUM_DIR} STREQUAL "") | ||
set(CMAKE_MODULE_PATH "${URANIUM_DIR}/cmake") | ||
@@ -80,10 +89,10 @@ | ||
DESTINATION lib${LIB_SUFFIX}/python${Python3_VERSION_MAJOR}/dist-packages/cura) | ||
else() | ||
install(DIRECTORY cura | ||
- DESTINATION lib${LIB_SUFFIX}/python${Python3_VERSION_MAJOR}.${Python3_VERSION_MINOR}/site-packages | ||
+ DESTINATION ${PYTHON_SITE_PACKAGES_DIR} | ||
FILES_MATCHING PATTERN *.py) | ||
install(FILES ${CMAKE_BINARY_DIR}/CuraVersion.py | ||
- DESTINATION lib${LIB_SUFFIX}/python${Python3_VERSION_MAJOR}.${Python3_VERSION_MINOR}/site-packages/cura) | ||
+ DESTINATION ${PYTHON_SITE_PACKAGES_DIR}/cura) | ||
endif() | ||
install(FILES ${CMAKE_BINARY_DIR}/cura.desktop | ||
DESTINATION ${CMAKE_INSTALL_DATADIR}/applications) |