forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/rosconsole_bridge: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
- Loading branch information
Showing
4 changed files
with
58 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST rosconsole_bridge-0.4.2.tar.gz 3974 SHA256 0834456f97e97f30ed27a6a234dac4e829970bffc20b439f4fcf442f0ba04d0c SHA512 ee44f0967d6325bdd20a6c0716502f93a39b5ac22ce9abbde906328ebb1e6fa61f1f4170f6a7fe2ea83cde255b9cb5159153ab23c911524743f0e63e6656330a WHIRLPOOL 3daee3baf0c80993596238304efb30ab59946e42de178db3b3c743eaa4f964a8b440b63120e87976d9af6372fcdf658f12a6e4a88b52af28583778915246cab1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<herd>ros</herd> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2014 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
ROS_REPO_URI="https://github.com/ros/rosconsole_bridge" | ||
KEYWORDS="~amd64 ~arm" | ||
|
||
inherit ros-catkin | ||
|
||
DESCRIPTION="Connects console_bridge-based logging to rosconsole-based logging" | ||
LICENSE="BSD" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
RDEPEND="dev-libs/console_bridge | ||
dev-ros/rosconsole" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
# fix libdir | ||
sed -i \ | ||
-e 's:DESTINATION lib:DESTINATION ${CMAKE_INSTALL_LIBDIR}:' \ | ||
CMakeLists.txt || die | ||
ros-catkin_src_prepare | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2014 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
ROS_REPO_URI="https://github.com/ros/rosconsole_bridge" | ||
KEYWORDS="~amd64 ~arm" | ||
|
||
inherit ros-catkin | ||
|
||
DESCRIPTION="Connects console_bridge-based logging to rosconsole-based logging" | ||
LICENSE="BSD" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
RDEPEND="dev-libs/console_bridge | ||
dev-ros/rosconsole" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
# fix libdir | ||
sed -i \ | ||
-e 's:DESTINATION lib:DESTINATION ${CMAKE_INSTALL_LIBDIR}:' \ | ||
CMakeLists.txt || die | ||
ros-catkin_src_prepare | ||
} |