Skip to content

Commit

Permalink
media-plugins/live: bump to 2018.07.07
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
aballier committed Jul 20, 2018
1 parent 4f3edd9 commit ef83eef
Show file tree
Hide file tree
Showing 2 changed files with 129 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/live/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST live.2017.10.28.tar.gz 629858 BLAKE2B a1d862ae1356b46fcd4e5ef7e27c47d3fb3abac35add6feb7955f60ddbd93e9242a84102393de67dda0d39c09632a0cc9a5f54d30c9f91d005696d3a566258bd SHA512 eea5bdb8d89e76c8b6aeb6ec04b77af3048cb41f228d230ba4da6045e9bc691a456023d44d8650fe690b08143567ed5af5b633f5b6522debff79344a813dc7d0
DIST live.2018.01.29.tar.gz 630144 BLAKE2B dd58865636a44ccabd0e3b02e1679393f17fb09d82455188d49d4fcb321b21e136a168c0f4c407c1dba3afcb5b541192cd2c5181d7a7710d39d4727526fc39cf SHA512 dfdfcac67acd28f651807de423c6aed00190cfc38ecd361b76d37d8cc27ee2fa91a42a5b8835045680fd7f65c847e41747b948c2c71e6530a3c7e89421c60227
DIST live.2018.07.07.tar.gz 630625 BLAKE2B 8545d4d8ed60328ccc782b6c2a8c4a0dc9ce3c1245fbc78fed4d3eb6f42de39c3c341456dc00cdc416fdcb2e518f5fe387273f5b4d2c3e2d32bfa22a21df2a90 SHA512 e7d4ddf51e9666c6ebe9a46976035b68fea94be54825535ffb04006cd242b9d3ad08250305206442bed3500d1e8d628ccf44302c485f63a9e244b3f8b1e27fe4
128 changes: 128 additions & 0 deletions media-plugins/live/live-2018.07.07.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,128 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit flag-o-matic eutils toolchain-funcs multilib multilib-minimal

DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
HOMEPAGE="http://www.live555.com/"
SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz
mirror://gentoo/${P/-/.}.tar.gz"

LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="examples static-libs"
DOCS=( "live-shared/README" )

# Alexis Ballier <[email protected]>
# Be careful, bump this everytime you bump the package and the ABI has changed.
# If you don't know, ask someone.
LIVE_ABI_VERSION=7
SLOT="0/${LIVE_ABI_VERSION}"

src_unpack() {
unpack ${A}
mkdir -p "${S}"
mv "${WORKDIR}/live" "${S}/" || die
}

src_prepare() {
epatch "${FILESDIR}/${PN}-recursive3.patch"

if use static-libs ; then
cp -pPR live live-shared
mv live live-static
else
mv live live-shared
fi

use static-libs && cp "${FILESDIR}/config.gentoo-r1" live-static/config.gentoo
cp "${FILESDIR}/config.gentoo-so-r2" live-shared/config.gentoo-so-r1

case ${CHOST} in
*-solaris*)
use static-libs && { sed -i \
-e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
-e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
live-static/config.gentoo \
|| die ; }
sed -i \
-e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
-e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
live-shared/config.gentoo-so-r1 \
|| die
;;
*-darwin*)
use static-libs && { sed -i \
-e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
-e '/^LINK /s/$/ /' \
-e '/^LIBRARY_LINK /s/$/ /' \
-e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
live-static/config.gentoo \
|| die static ; }
sed -i \
-e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
-e '/^LINK /s/$/ /' \
-e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
-e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
-e '/^LIB_SUFFIX /s/so/dylib/' \
live-shared/config.gentoo-so-r1 \
|| die shared
;;
esac
multilib_copy_sources
}

src_configure() { :; }

multilib_src_compile() {
tc-export CC CXX LD

if use static-libs ; then
cd "${BUILD_DIR}/live-static"

einfo "Beginning static library build"
./genMakefiles gentoo
emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
fi

cd "${BUILD_DIR}/live-shared"
einfo "Beginning shared library build"
./genMakefiles gentoo-so-r1
local suffix=$(get_libname ${LIVE_ABI_VERSION})
emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"

for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
pushd "${BUILD_DIR}/live-shared/${i}" > /dev/null
ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
popd > /dev/null
done

if multilib_is_native_abi; then
einfo "Beginning programs build"
for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
cd "${BUILD_DIR}/live-shared/${i}"
emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
done
fi
}

multilib_src_install() {
for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
use static-libs && dolib.a live-static/${library}/lib${library}.a
dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)

insinto /usr/include/${library}
doins live-shared/${library}/include/*h
done

if multilib_is_native_abi; then
# Should we really install these?
use examples && find live-shared/testProgs -type f -perm 755 -print0 | \
xargs -0 dobin

dobin live-shared/mediaServer/live555MediaServer
dobin live-shared/proxyServer/live555ProxyServer
fi
}

0 comments on commit ef83eef

Please sign in to comment.