Skip to content

Commit

Permalink
dev-qt/qtquick3d: add 6.6.0
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Oct 10, 2023
1 parent 41e9e28 commit ef9a836
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtquick3d/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qtquick3d-everywhere-src-6.5.2.tar.xz 59171420 BLAKE2B 91012368061acf6c4057362a380fea2e3fdc46cf63644a667d7b05450fbbeb8c8dae3765c5617fec8c8a1fd3f880fad21c8e6524c3240f040c9dfdbb80869423 SHA512 2a26f4fa4e4d88b4205813a8bba1c83811354e5ad5e7aa832fd46c5956b46d15e690c359d83f85018c1430e15edd151207411a50227855de4fc8451db710ace2
DIST qtquick3d-everywhere-src-6.5.3.tar.xz 59323996 BLAKE2B 727798e3a4e6d9c3d3d22881e3b8d0b3b3475c57627adf0e7bb4cf64aa9cbed2c3dce8282744e4ca6aa558a9a399b604b634bfa2dac8a0cd915ec236ca109fe1 SHA512 85611eba47239c342159e704826cdcb7ec2cd79118aaad081d4924c5697b71eddf4307682e9dde23bf973641df2e90301e26f381aa29c023e386918e8d1f7f70
DIST qtquick3d-everywhere-src-6.6.0.tar.xz 59166200 BLAKE2B ad2912c69487a7fd011ba294e4f38f8937b050c28f67a599329a2f4c55a0fadd108093dfaac42a0fc267c1117494841f8057dbfc67cf11dd8a9d442de4f21b85 SHA512 309800ad6afc1959d83d7dba97af41954b813486740f99747df6d997a3420c3a9fcc97e52ae67a390b34885ca9bc683cdecea55dd2ab4b530e7594654fa13454
42 changes: 42 additions & 0 deletions dev-qt/qtquick3d/qtquick3d-6.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit qt6-build

DESCRIPTION="Qt module and API for defining 3D content in Qt QuickTools"

if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
elif [[ ${QT6_BUILD_TYPE} == live ]]; then
EGIT_SUBMODULES=() # skip qtquick3d-assimp
fi

IUSE="opengl vulkan"

RDEPEND="
~dev-qt/qtbase-${PV}:6[concurrent,gui,opengl=,vulkan=,widgets]
~dev-qt/qtdeclarative-${PV}:6
~dev-qt/qtquicktimeline-${PV}:6
~dev-qt/qtshadertools-${PV}:6
media-libs/assimp:=
sys-libs/zlib:=
"
DEPEND="
${RDEPEND}
test? ( ~dev-qt/qtbase-${PV}:6[network] )
"

CMAKE_SKIP_TESTS=(
# collada support is disabled in system media-libs/assimp (bug #891787)
tst_qquick3dassetimport
)

src_configure() {
local mycmakeargs=(
-DQT_FEATURE_system_assimp=ON
)

qt6-build_src_configure
}

0 comments on commit ef9a836

Please sign in to comment.