Skip to content

Commit

Permalink
media-libs/netpbm: bump to v10.86.26
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Viorel Munteanu <[email protected]>
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ceamac authored and ionenwks committed Nov 28, 2021
1 parent f212b92 commit efa88cb
Show file tree
Hide file tree
Showing 2 changed files with 220 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/netpbm/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST netpbm-10.70.00.tar.xz 2621612 BLAKE2B 2b07d130de0afeb3c1df32c6d267bc6bd13d4f556988cb7784b51941d81de1ad4f3381a0788eec6309bc6c024a21eb273a5f00726f6bb9a8ecb87f547678fc77 SHA512 f70d6dd79ce813f9fc4935d382b50bd3cecdf02c324b0f012056e56e33f24b621e8c1b3d054c6f470d437d0d793593de95eaa9724055d59c342228398a40f0b4
DIST netpbm-10.76.00.tar.xz 2657184 BLAKE2B b8d82268ba50881fab10bca00ea408afa39096f4f9c079b523d8e28ce62301797ee50f55c84f85a6d832b723da7449531e725bf60a4a89975c51382b2cbc4a94 SHA512 234a5616a7631a8eb70817bb88ed509ddddfce93f71739654ef78a2735245b268c391adb49b514ed883569c9fc6ea9c3eeed10aa7898c02b797fee5249b11cf3
DIST netpbm-10.86.24.tar.xz 3698448 BLAKE2B 189fbaeb91db15e317c62758c64d1165d3cb32fa0221b2dcdefb0425577d4af9a13e66c35774149a44727c99fc18263123fd3c2b71f6409344bcf458341a4470 SHA512 50ad5a726c4219e1d87c7a46868b8f7bdb2d676903f049816b58e00addb416e4684a6c669188beebc5cc3c3961d2b0e35cd663215196d9925e3a23a989e14be3
DIST netpbm-10.86.26.tar.xz 3699572 BLAKE2B d0b3fccfecea20a7979a6b29dac670dc33616a6cdd6f985af76cbd0d8125b887ad2dfc193e5e59f47014f685887cadeebcdce0da8db0a219457bb88caf42ba62 SHA512 23ca6125827c61648e0a475880efade7b83f87cfc884361c1f706f0a69ac70b5a7a2ae4699c77e21eda1c73241768b1bd7e595d5d533eeb10b7f69a79c7ae69d
219 changes: 219 additions & 0 deletions media-libs/netpbm/netpbm-10.86.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,219 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit multilib toolchain-funcs

DESCRIPTION="A set of utilities for converting to/from the netpbm (and related) formats"
HOMEPAGE="http://netpbm.sourceforge.net/"
SRC_URI="https://github.com/ceamac/netpbm-make-dist/releases/download/v${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc jbig jpeg png postscript rle cpu_flags_x86_sse2 static-libs svga tiff X xml zlib"
# zlib USE flag is no longer used, enabled by default.
# cannot remove it yet because of #801445

BDEPEND="
app-arch/xz-utils
sys-devel/flex
virtual/pkgconfig
"
# app-text/ghostscript-gpl is really needed for postscript
# some utilities execute /usr/bin/gs
RDEPEND="jbig? ( media-libs/jbigkit:= )
jpeg? ( virtual/jpeg:0 )
png? (
>=media-libs/libpng-1.4:0=
sys-libs/zlib
)
postscript? (
app-text/ghostscript-gpl
sys-libs/zlib
)
rle? ( media-libs/urt:= )
svga? ( media-libs/svgalib )
tiff? ( >=media-libs/tiff-3.5.5:0 )
xml? ( dev-libs/libxml2 )
X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/netpbm-10.86.21-build.patch
"${FILESDIR}"/netpbm-10.86.21-test.patch #450530
"${FILESDIR}"/netpbm-10.86.21-misc-deps.patch
"${FILESDIR}"/netpbm-10.86.22-fix-ps-test.patch #670362
)

netpbm_libtype() {
case ${CHOST} in
*-darwin*) echo dylib;;
*) echo unixshared;;
esac
}

netpbm_libsuffix() {
local suffix=$(get_libname)
echo ${suffix//\.}
}

netpbm_ldshlib() {
case ${CHOST} in
*-darwin*) echo '$(LDFLAGS) -dynamiclib -install_name $(SONAME)';;
*) echo '$(LDFLAGS) -shared -Wl,-soname,$(SONAME)';;
esac
}
netpbm_config() {
if use ${1} ; then
[[ ${2} != "!" ]] && echo -l${2:-$1}
else
echo NONE
fi
}

src_prepare() {
default

# make sure we use system libs
sed -i '/SUPPORT_SUBDIRS/s:urt::' GNUmakefile || die
rm -r urt converter/other/jbig/libjbig converter/other/jpeg2000/libjasper || die

# take care of the importinc stuff ourselves by only doing it once
# at the top level and having all subdirs use that one set #149843
sed -i \
-e '/^importinc:/s|^|importinc:\nmanual_|' \
-e '/-Iimportinc/s|-Iimp|-I"$(BUILDDIR)"/imp|g'\
common.mk || die
sed -i \
-e '/%.c/s: importinc$::' \
common.mk lib/Makefile lib/util/Makefile || die
sed -i \
-e 's:pkg-config:$(PKG_CONFIG):' \
GNUmakefile converter/other/Makefile other/pamx/Makefile || die

# The postscript knob is currently bound up with a fork test.
if ! use postscript ; then
sed -i \
-e 's:$(DONT_HAVE_PROCESS_MGMT):Y:' \
converter/other/Makefile generator/Makefile || die
sed -i -r \
-e 's:(pbmtextps|pnmtops|pstopnm).*::' \
test/all-in-place.{ok,test} || die
sed -i -e 's:lps-roundtrip.*::' test/Test-Order || die
sed -i -e '/^$/d' test/all-in-place.ok || die
sed -i '2iexit 80' test/ps-{alt-,flate-,}roundtrip.test || die
fi

# the new postscript test needs +x
chmod +x test/lps-roundtrip.test

# Do not test png if not built
if ! use png ; then
sed -i -r \
-e 's:(pamtopng|pngtopam|pnmtopng).*::' \
test/all-in-place.{ok,test} || die
sed -i -e '/^$/d' test/all-in-place.ok || die

sed -i -r \
-e 's:(pamrgbatopng|pngtopnm).*::' \
test/legacy-names.{ok,test} || die
sed -i -e '/^$/d' test/legacy-names.ok || die
sed -i -e 's:png-roundtrip.*::' test/Test-Order || die
fi
}

src_configure() {
# cannot chain the die with the heredoc
# repoman tries to parse the heredoc and fails
cat config.mk.in - >> config.mk <<-EOF
# Misc crap
BUILD_FIASCO = N
SYMLINK = ln -sf
# These vars let src_test work by default
PKGDIR_DEFAULT = ${T}/netpbm
RESULTDIR_DEFAULT = ${T}/netpbm-test
# Toolchain options
CC = $(tc-getCC) -Wall
LD = \$(CC)
CC_FOR_BUILD = $(tc-getBUILD_CC)
LD_FOR_BUILD = \$(CC_FOR_BUILD)
AR = $(tc-getAR)
RANLIB = $(tc-getRANLIB)
PKG_CONFIG = $(tc-getPKG_CONFIG)
STRIPFLAG =
CFLAGS_SHLIB = -fPIC
LDRELOC = \$(LD) -r
LDSHLIB = $(netpbm_ldshlib)
LINKER_CAN_DO_EXPLICIT_LIBRARY = N # we can, but dont want to
LINKERISCOMPILER = Y
NETPBMLIBSUFFIX = $(netpbm_libsuffix)
NETPBMLIBTYPE = $(netpbm_libtype)
STATICLIB_TOO = $(usex static-libs Y N)
# The var is called SSE, but the code is actually SSE2.
WANT_SSE = $(usex cpu_flags_x86_sse2 Y N)
# Gentoo build options
TIFFLIB = $(netpbm_config tiff)
# Let tiff worry about its own dependencies #395753
TIFFLIB_NEEDS_JPEG = N
TIFFLIB_NEEDS_Z = N
JPEGLIB = $(netpbm_config jpeg)
PNGLIB = $(netpbm_config png)
ZLIB = $($(tc-getPKG_CONFIG) --libs zlib)
LINUXSVGALIB = $(netpbm_config svga vga)
XML2_LIBS = $(netpbm_config xml xml2)
JBIGLIB = $(netpbm_config jbig)
JBIGHDR_DIR =
JASPERLIB = NONE
JASPERHDR_DIR =
URTLIB = $(netpbm_config rle)
URTHDR_DIR =
X11LIB = $(netpbm_config X X11)
X11HDR_DIR =
EOF
[[ $? -eq 0 ]] || die "writing config.mk failed"
}

src_compile() {
emake -j1 pm_config.h version.h manual_importinc #149843
emake
}

src_test() {
# The code wants to install everything first and then test the result.
emake install.{bin,lib,data}
emake check
}

src_install() {
# Subdir make targets like to use `mkdir` all over the place
# without any actual dependencies, thus the -j1.
emake -j1 package pkgdir="${ED}"/usr

if [[ $(get_libdir) != "lib" ]] ; then
mv "${ED}"/usr/lib "${ED}"/usr/$(get_libdir) || die
fi

# Remove cruft that we don't need, and move around stuff we want
rm "${ED}"/usr/{README,VERSION,{pkgconfig,config}_template,pkginfo} || die

dodir /usr/share
mv "${ED}"/usr/misc "${ED}"/usr/share/netpbm || die

doman userguide/*.[0-9]
dodoc README

cd doc || die
dodoc HISTORY Netpbm.programming USERDOC
docinto html
dodoc -r *.html

use doc && dodoc -r ../userguide/*.html
}

0 comments on commit efa88cb

Please sign in to comment.