Skip to content

Commit

Permalink
dev-python/uvicorn: Bump to 0.17.5
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 16, 2022
1 parent 8d220be commit efe96de
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/uvicorn/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST uvicorn-0.17.0.tar.gz 708241 BLAKE2B 77f87f0ecb911bb19d599fd48d6ea51105c194
DIST uvicorn-0.17.1.tar.gz 708124 BLAKE2B ee376b5d5c23c955dde9a8994ef589bcaa253f4c35617faa6996f5e2e82ea9268f59e25a0c9a092383ba308a03d98c2964b11d7997a3265dd13d3736a48b89ec SHA512 3a34f04757c4487d64351359da5e12b0ae9cd617ab8cab79cfe8c1e3521c91b324ff253c3dcf774b897c06b24e8e78c0c4c4ee52e7bce4971cba2b3d4fe90b2d
DIST uvicorn-0.17.3.tar.gz 706936 BLAKE2B f96f1707fc966f2972392a413517ba4f3f65097c83134bd648a759ef65496ffa166507d64a2c51d5c301adab4203e0766ab2b359d1182dceeb31dd70e6bbf8e3 SHA512 d2a35a69420b2715c2688be341860958b8697c1565d5b2665d4b9c6fa7bf72060e61f72bfd99fb7c346df48f4a962e3c7a7118dd1d0782bc35ac0fcc57cb4e1d
DIST uvicorn-0.17.4.tar.gz 706950 BLAKE2B 51d30a97f70984929bc4d4eb3934a16514307ff3e504f86813d0b5ea81467cc5fcc06da6aaa298f0319b2ccddf88b02ee4006ba9f1d573da50365cc4455f5da3 SHA512 4e61d712551ee6e6471f88f511e31b5543ef16d8ebe960447f5de6d02753bdbc38fd5fbae0d736b54b01a61d8519ef3891db2bbc1c7440806650b92a765d1d23
DIST uvicorn-0.17.5.tar.gz 707840 BLAKE2B 70a5aa4c084f63231b2c4f11c9a4add6a84362789243fe59b4c954665b67f859dcd92076454cac7b960d30c878bccb52e6da5232e052d70ca0a71f4035804b96 SHA512 b73c99d03957bf5f37957386da77cad68e0c9603fb0bfe48ab81f1066953ca01bc75b2eb458a20a587df4f2e1f591fe1c56f26d8df84070c833ccbb912d55ca2
47 changes: 47 additions & 0 deletions dev-python/uvicorn/uvicorn-0.17.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )

inherit distutils-r1

DESCRIPTION="Lightning-fast ASGI server implementation"
HOMEPAGE="https://www.uvicorn.org/"
SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"

RDEPEND="
>=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
>=dev-python/click-7.0[${PYTHON_USEDEP}]
>=dev-python/h11-0.8[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/httpx[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/python-dotenv[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
>=dev-python/websockets-10.0[${PYTHON_USEDEP}]
dev-python/watchgod[${PYTHON_USEDEP}]
dev-python/wsproto[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

EPYTEST_DESELECT=(
# too long path for unix socket
tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
# need unpackaged httptools
"tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
tests/protocols/test_http.py::test_fragmentation
)

0 comments on commit efe96de

Please sign in to comment.