Skip to content

Commit

Permalink
dev-vcs/git: Synced live ebuilds
Browse files Browse the repository at this point in the history
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Oct 13, 2021
1 parent 46bc1f5 commit f002334
Show file tree
Hide file tree
Showing 4 changed files with 18 additions and 18 deletions.
10 changes: 5 additions & 5 deletions dev-vcs/git/git-9999-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

GENTOO_DEPEND_ON_PERL=no

Expand Down Expand Up @@ -46,7 +46,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
[[ "${PV}" == *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

LICENSE="GPL-2"
Expand Down Expand Up @@ -141,7 +141,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
"${FILESDIR}"/git-2.31.0_rc0-optional-cvs.patch
"${FILESDIR}"/git-2.33.0_rc0-optional-cvs.patch

# Make submodule output quiet
"${FILESDIR}"/git-2.21.0-quiet-submodules-testcase.patch
Expand Down Expand Up @@ -319,7 +319,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi

if [[ ${CHOST} == *-darwin* ]]; then
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
Expand Down Expand Up @@ -366,7 +366,7 @@ src_compile() {
src_install() {
git_emake install || die "make install failed"

if [[ ${CHOST} == *-darwin* ]]; then
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi

Expand Down
10 changes: 5 additions & 5 deletions dev-vcs/git/git-9999-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

GENTOO_DEPEND_ON_PERL=no

Expand Down Expand Up @@ -46,7 +46,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
[[ "${PV}" == *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

LICENSE="GPL-2"
Expand Down Expand Up @@ -141,7 +141,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
"${FILESDIR}"/git-2.31.0_rc0-optional-cvs.patch
"${FILESDIR}"/git-2.33.0_rc0-optional-cvs.patch

# Make submodule output quiet
"${FILESDIR}"/git-2.21.0-quiet-submodules-testcase.patch
Expand Down Expand Up @@ -319,7 +319,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi

if [[ ${CHOST} == *-darwin* ]]; then
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
Expand Down Expand Up @@ -366,7 +366,7 @@ src_compile() {
src_install() {
git_emake install || die "make install failed"

if [[ ${CHOST} == *-darwin* ]]; then
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi

Expand Down
6 changes: 3 additions & 3 deletions dev-vcs/git/git-9999-r3.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

GENTOO_DEPEND_ON_PERL=no

Expand Down Expand Up @@ -46,7 +46,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
[[ "${PV}" == *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

LICENSE="GPL-2"
Expand Down Expand Up @@ -141,7 +141,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
"${FILESDIR}"/git-2.31.0_rc0-optional-cvs.patch
"${FILESDIR}"/git-2.33.0_rc0-optional-cvs.patch

# Make submodule output quiet
"${FILESDIR}"/git-2.21.0-quiet-submodules-testcase.patch
Expand Down
10 changes: 5 additions & 5 deletions dev-vcs/git/git-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

GENTOO_DEPEND_ON_PERL=no

Expand Down Expand Up @@ -46,7 +46,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
[[ "${PV}" == *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

LICENSE="GPL-2"
Expand Down Expand Up @@ -141,7 +141,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
"${FILESDIR}"/git-2.22.0_rc0-optional-cvs.patch
"${FILESDIR}"/git-2.33.0_rc0-optional-cvs.patch

# Make submodule output quiet
"${FILESDIR}"/git-2.21.0-quiet-submodules-testcase.patch
Expand Down Expand Up @@ -319,7 +319,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi

if [[ ${CHOST} == *-darwin* ]]; then
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
Expand Down Expand Up @@ -366,7 +366,7 @@ src_compile() {
src_install() {
git_emake install || die "make install failed"

if [[ ${CHOST} == *-darwin* ]]; then
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi

Expand Down

0 comments on commit f002334

Please sign in to comment.