forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <[email protected]>
- Loading branch information
Showing
4 changed files
with
169 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST nautilus-3.30.5.tar.xz 3254344 BLAKE2B 64da158ee661fc259a14f890bf6ad343f720245df6b9475ff047993570ea4e7234723eb242f057bc85b7ea95d38a99b5c2f5d546e982a3e3e32b7fc75cabb786 SHA512 e38a8bb380460d902e4ec6219d0e147a4245e790b18fb18ab9474ec2ae002a971243c6b09b8fec267e65c7ecc7bb1217191c4f5cb9547b3b9d5b0793068103cf | ||
DIST nautilus-3.32.3.tar.xz 3197820 BLAKE2B 28140210a855fe62faba4f0833067a81c4d8f71c0cc870ba4fdcc016754b01df003e45f636836f67cced8515aba8c8fb7922de788a14bfe0f0cc4518010aed5f SHA512 f19710f02bd91edb2d2f6cb8f46be6bebea3edfed14a07612444d5990533bafd032b604d65533727eb377b574d6bd4c82dbe11894d85ad254ee1473b683c4392 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
From f2d55bc9a9398ed1c36e1b856bcb33080abbf7c0 Mon Sep 17 00:00:00 2001 | ||
From: Mart Raudsepp <[email protected]> | ||
Date: Thu, 19 Sep 2019 22:26:08 +0300 | ||
Subject: [PATCH] build: Optional gstreamer | ||
|
||
--- | ||
extensions/meson.build | 4 +++- | ||
meson.build | 2 ++ | ||
meson_options.txt | 6 ++++++ | ||
3 files changed, 11 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/extensions/meson.build b/extensions/meson.build | ||
index 5c6f64cef..bd8c41d3e 100644 | ||
--- a/extensions/meson.build | ||
+++ b/extensions/meson.build | ||
@@ -1,3 +1,5 @@ | ||
subdir('image-properties') | ||
-subdir('audio-video-properties') | ||
+if get_option('gstreamer') | ||
+ subdir('audio-video-properties') | ||
+endif | ||
subdir('sendto') | ||
diff --git a/meson.build b/meson.build | ||
index 0a267d670..ccb2b8cc1 100644 | ||
--- a/meson.build | ||
+++ b/meson.build | ||
@@ -122,8 +122,10 @@ libm = cc.find_library('m') | ||
|
||
if get_option('extensions') | ||
gexiv = dependency('gexiv2', version: '>= 0.10.0') | ||
+ if get_option('gstreamer') | ||
gst_tag_dep = dependency('gstreamer-tag-1.0') | ||
gst_pbutils_dep = dependency('gstreamer-pbutils-1.0') | ||
+ endif | ||
endif | ||
gio = dependency('gio-2.0', version: glib_ver) | ||
gio_unix = dependency('gio-unix-2.0', version: glib_ver) | ||
diff --git a/meson_options.txt b/meson_options.txt | ||
index fce5f16f9..1fa8f8952 100644 | ||
--- a/meson_options.txt | ||
+++ b/meson_options.txt | ||
@@ -13,6 +13,12 @@ option( | ||
value: true, | ||
description: 'Build stock extensions', | ||
) | ||
+option( | ||
+ 'gstreamer', | ||
+ type: 'boolean', | ||
+ value: true, | ||
+ description: 'Build audio-video properties extension (requires "extensions")', | ||
+) | ||
option( | ||
'introspection', | ||
type: 'boolean', | ||
-- | ||
2.20.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,110 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg | ||
|
||
DESCRIPTION="Default file manager for the GNOME desktop" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus" | ||
|
||
LICENSE="GPL-3+ LGPL-2.1+" | ||
SLOT="0" | ||
IUSE="gnome +gstreamer gtk-doc +introspection packagekit +previewer seccomp selinux sendto" | ||
|
||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.58.1:2 | ||
>=media-libs/gexiv2-0.10.0 | ||
gstreamer? ( media-libs/gstreamer:1.0 | ||
media-libs/gst-plugins-base:1.0 ) | ||
>=app-arch/gnome-autoar-0.2.1 | ||
gnome-base/gsettings-desktop-schemas | ||
>=x11-libs/gtk+-3.22.27:3[X,introspection?] | ||
seccomp? ( sys-libs/libseccomp ) | ||
>=x11-libs/pango-1.28.3 | ||
selinux? ( >=sys-libs/libselinux-2.0 ) | ||
>=app-misc/tracker-2.0:= | ||
x11-libs/libX11 | ||
>=dev-libs/libxml2-2.7.8:2 | ||
introspection? ( >=dev-libs/gobject-introspection-1.54:= ) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
packagekit? ( app-admin/packagekit-base ) | ||
seccomp? ( >=sys-apps/bubblewrap-0.3.1 ) | ||
sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 ) | ||
gstreamer? ( !<media-video/totem-3.31.91[nautilus] ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
media-libs/fontconfig | ||
" | ||
BDEPEND=" | ||
>=dev-util/gdbus-codegen-2.51.2 | ||
dev-util/glib-utils | ||
gtk-doc? ( | ||
>=dev-util/gtk-doc-1.10 | ||
app-text/docbook-xml-dtd:4.1.2 ) | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
x11-base/xorg-proto | ||
" | ||
PDEPEND=" | ||
gnome? ( x11-themes/adwaita-icon-theme ) | ||
previewer? ( >=gnome-extra/sushi-0.1.9 ) | ||
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 ) | ||
>=gnome-base/gvfs-1.14[gtk(+)] | ||
" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34 | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/3.30.5-docs-build.patch # Always install pregenerated manpage, keeping docs option for gtk-doc | ||
"${FILESDIR}"/${PV}-optional-gstreamer.patch # Allow controlling audio-video-properties build | ||
) | ||
|
||
src_prepare() { | ||
if use previewer; then | ||
DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files. | ||
To activate the previewer, select a file and press space; to | ||
close the previewer, press space again." | ||
fi | ||
xdg_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
$(meson_use gtk-doc docs) | ||
-Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true | ||
$(meson_use gstreamer) # gstreamer audio-video-properties extension | ||
$(meson_use introspection) | ||
$(meson_use packagekit) | ||
$(meson_use selinux) | ||
-Dprofiling=false | ||
-Dtests=$(usex test all none) | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_install() { | ||
use previewer && readme.gentoo_create_doc | ||
meson_src_install | ||
} | ||
|
||
src_test() { | ||
virtx meson_src_test | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
|
||
if use previewer; then | ||
readme.gentoo_print_elog | ||
else | ||
elog "To preview media files, emerge nautilus with USE=previewer" | ||
fi | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_schemas_update | ||
} |