Skip to content

Commit

Permalink
dev-libs/libcss: version bump to 0.9.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Philipp Ammann <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
trilean authored and juippis committed Dec 4, 2019
1 parent 1fb5784 commit f02e04d
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libcss/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libcss-0.8.0-src.tar.gz 516474 BLAKE2B 937adc65f68fecece189e0f06cfd601ae2d76f0b4dcdbcb8a67f3f058c4355c19c12c088fb50ecf1e6bcd8436c867b1845b3da27bb44b5d1a009bd946bf5e53e SHA512 fb52920ce462f442dfafa7b0061fa465e6c04827d26186e8468855c2a40e8f34e6f0689d5eb58cb0b2ee0759d083fcff5c8c583e1d98693755003c352a22a4be
DIST libcss-0.9.0-src.tar.gz 522267 BLAKE2B c104dd2cf859b908d68ac318d1da0430733b8813fbfbcb1f8f6a3d373e3a2ba1db6685542823fe0bef838619ec358f336f8eb07dc073a55a2f8c1907727295b9 SHA512 435dbca91aa2b91398dddbc1d9d035d104be193bb593907e3fff9320cc4f668f8aae54e0d5d0b7cd2ed9cb36fc02255fbe97bc9038b79fe505b581d6af1ded0d
50 changes: 50 additions & 0 deletions dev-libs/libcss/libcss-0.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="CSS parser and selection engine, written in C"
HOMEPAGE="http://www.netsurf-browser.org/projects/libcss/"
SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~m68k-mint"
IUSE="test"

RDEPEND="
dev-libs/libparserutils
dev-libs/libwapcaplet"
DEPEND="${RDEPEND}
test? ( dev-lang/perl )"
BDEPEND="
>=dev-util/netsurf-buildsystem-1.7-r1
virtual/pkgconfig"

src_prepare() {
default
sed -e '1i#pragma GCC diagnostic ignored "-Wimplicit-fallthrough"' \
-i src/parse/parse.c src/select/arena_hash.h || die
sed -e '1i#pragma GCC diagnostic ignored "-Wmaybe-uninitialized"' \
-i src/parse/parse.c src/select/computed.c || die
}

_emake() {
source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
netsurf_define_makeconf
emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
}

src_compile() {
_emake
}

src_test() {
_emake test
}

src_install() {
_emake DESTDIR="${ED}" install
}

0 comments on commit f02e04d

Please sign in to comment.