Skip to content

Commit

Permalink
app-i18n/man-pages-ja: partially revert a03e0fb.
Browse files Browse the repository at this point in the history
  The stable version is needed for a while.

Package-Manager: Portage-2.3.16, Repoman-2.3.6
RepoMan-Options: --force
  • Loading branch information
heroxbd committed Dec 21, 2017
1 parent b445ecd commit f032bae
Show file tree
Hide file tree
Showing 2 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-i18n/man-pages-ja/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST man-pages-ja-20130215.tar.gz 4384182 BLAKE2B eb6a4be0a53763776b629369028eeae96f472a8dcb0752559d124cbffc7b18a5d939fe6e37d05c1162aeec79701c63fe1602754f260edbb281cd543144d98c77 SHA512 655e9481dfdfc619013f8cae2928d7ccd70bba31631f7b10b894b1d96ab64bae4846be68d8a633791f1c169faed6d42466bd60ee4d7f92031f596d8f23cb6138
DIST man-pages-ja-20171215.tar.gz 4802604 BLAKE2B 24ded9e82f20df322fa7e96a05806f37f26796475f64e2b075a60b60762e4b331c96e82e0582896da323a643070779204fb50eb8e68156ba2e74a1a41649f10e SHA512 8cef4489e3210c2e30fd880c1639aaf314005c7f3987001677cd869924275cbf9df27fdc855cba9d887e5a185da72779167227a68a080d370b233bcd4eca4d30
DIST portage-man-pages-ja-20060415.tar.gz 67347 BLAKE2B 77be89a79be1d4fc3c09cd7c74cd8ccfd18649cdf0121daec008b21114c5a77618a88f4abed266599b944aa5bf11fe55c5b6e89fbba51ebe2a548eb85d9a2c6d SHA512 37364cdcb27b460663bdae31fea1ac653317ba4d928a5325c51814eb1677d7d9fb9bcc55cf64d63a8e6daaefa34d8604e0efe3582308957397cad31325a6eaad
92 changes: 92 additions & 0 deletions app-i18n/man-pages-ja/man-pages-ja-20130215.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,92 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="3"
GENTOO_MAN_P="portage-${PN}-20060415"

DESCRIPTION="A collection of manual pages translated into Japanese"
HOMEPAGE="http://linuxjm.sourceforge.jp/ http://www.gentoo.gr.jp/jpmain/translation.xml"
SRC_URI="http://linuxjm.sourceforge.jp/${P}.tar.gz
https://dev.gentoo.org/~hattya/distfiles/${GENTOO_MAN_P}.tar.gz"

LICENSE="GPL-2+ GPL-2 LGPL-2+ LGPL-2 BSD MIT ISC HPND FDL-1.1+ LDP-1 LDP-1a man-pages Texinfo-manual"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE=""

RDEPEND="virtual/man"

src_prepare() {

sed -i -e "/^\(man\|shadow\)/s:Y:N:" script/pkgs.list || die

# remove man pages that are provided by other packages.
# - sys-apps/shadow +nls
rm -f manual/*/man1/{chfn,chsh,newgrp,su,passwd,groups}.1 || die
rm -f manual/*/man8/{vigr,vipw}.8 || die
# - app-arch/rpm +nls
rm -f manual/rpm/man8/rpm*.8 || die

for f in manual/*/man8/ld{,-linux}.so.8 ; do
mv ${f} ${f/.so.8/.so.ja.8} || die
done
mv "${WORKDIR}"/${GENTOO_MAN_P}/portage/g-cpan.pl{,.ja}.1 || die
}

src_compile() {
:
}

src_install() {

local x y z pkg

for x in $(tac script/pkgs.list | grep -v '^[#].*'); do
if [[ -z "$pkg" ]]; then
pkg=$x
continue
fi

if [[ "$x" == "N" ]]; then
pkg=
continue
fi

einfo "install $pkg"

for y in $(ls -d manual/$pkg/man* 2>/dev/null); do
doman -i18n=ja $y/*
done

pkg=
done

dodoc README || die

cd "${WORKDIR}"/${GENTOO_MAN_P}

for x in *; do
if [ -d "$x" ]; then
einfo "install $x"

for z in $(for y in $x/*.[1-9]; do echo ${y##*.}; done | sort | uniq); do
doman -i18n=ja $x/*.$z
done
fi
done

newdoc ChangeLog ChangeLog.GentooJP || die

}

pkg_postinst() {

echo
elog "You need to set appropriate LANG variables to use"
elog "Japanese manpages."
elog "e.g."
elog "\tLANG=\"ja_JP.eucJP\""
elog "\texport LANG"
echo

}

0 comments on commit f032bae

Please sign in to comment.