Skip to content

Commit

Permalink
app-mobilephone/wammu: Test LINGUAS rather than linguas_* USE flags.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
ulm committed Jan 6, 2018
1 parent 4fd67be commit f032ecb
Show file tree
Hide file tree
Showing 2 changed files with 8 additions and 30 deletions.
19 changes: 4 additions & 15 deletions app-mobilephone/wammu/wammu-0.40.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand All @@ -25,29 +25,18 @@ RDEPEND="|| ( ( >=app-mobilephone/gammu-1.36 dev-python/python-gammu )
DEPEND="${RDEPEND}"

# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"

# Required to source locale content out of the box
DISTUTILS_IN_SOURCE_BUILD=1

src_prepare() {
local lang support_linguas=no
local lang
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
support_linguas=yes
break
if ! has ${lang} ${LINGUAS-${lang}} ; then
rm -r locale/${lang} || die
fi
done
# install all languages when all selected LINGUAS aren't supported
if [ "${support_linguas}" = "yes" ]; then
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if ! use linguas_${lang} ; then
rm -r locale/${lang} || die
fi
done
fi

distutils-r1_src_prepare
}
Expand Down
19 changes: 4 additions & 15 deletions app-mobilephone/wammu/wammu-0.43.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -27,29 +27,18 @@ RDEPEND="
DEPEND="${RDEPEND}"

# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"

# Required to source locale content out of the box
DISTUTILS_IN_SOURCE_BUILD=1

src_prepare() {
local lang support_linguas=no
local lang
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
support_linguas=yes
break
if ! has ${lang} ${LINGUAS-${lang}} ; then
rm -r locale/${lang} || die
fi
done
# install all languages when all selected LINGUAS aren't supported
if [ "${support_linguas}" = "yes" ]; then
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if ! use linguas_${lang} ; then
rm -r locale/${lang} || die
fi
done
fi

distutils-r1_src_prepare
}
Expand Down

0 comments on commit f032ecb

Please sign in to comment.