Skip to content

Commit

Permalink
dev-libs/boost-1.55.0-r1: Backport fix for python ABI letters
Browse files Browse the repository at this point in the history
Also backport cross-compiler support

Reported-by: Nikolaos Chatzidakis <[email protected]>
Gentoo-Bug: 578354
Gentoo-Bug: 565090

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
Pinkbyte committed Jun 1, 2016
1 parent f7f6a67 commit f1399e6
Showing 1 changed file with 15 additions and 2 deletions.
17 changes: 15 additions & 2 deletions dev-libs/boost/boost-1.55.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -75,7 +75,20 @@ create_user-config.jam() {
fi

if python_bindings_needed; then
python_configuration="using python : : ${PYTHON} ;"
# boost expects libpython$(pyver) and doesn't allow overrides
# and the build system is so creepy that it's easier just to
# provide a symlink (linker's going to use SONAME anyway)
# TODO: replace it with proper override one day
ln -f -s "$(python_get_library_path)" "${T}/lib${EPYTHON}$(get_libname)" || die

if tc-is-cross-compiler; then
python_configuration="using python : ${EPYTHON#python} : : ${SYSROOT:-${EROOT}}/usr/include/${EPYTHON} : ${SYSROOT:-${EROOT}}/usr/$(get_libdir) ;"
else
# note: we need to provide version explicitly because of
# a bug in the build system:
# https://github.com/boostorg/build/pull/104
python_configuration="using python : ${EPYTHON#python} : ${PYTHON} : $(python_get_includedir) : ${T} ;"
fi
fi

cat > "${BOOST_ROOT}/user-config.jam" << __EOF__
Expand Down

0 comments on commit f1399e6

Please sign in to comment.