Skip to content

Commit

Permalink
dev-libs/cJSON: Version bump to 1.7.15
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Aug 28, 2021
1 parent 623c5df commit f16b719
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/cJSON/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cJSON-1.7.14.tar.gz 352028 BLAKE2B 203795f004496793fb04577df1e4a917df2424bf7866e32459584d3dc776ee13263c5e62ded01e3776973d2210e642d1066d3126e2c737bd0fa048464f3aed84 SHA512 8de1dedc123ed025a9cbe6764e5963eb0550f726d06a8f6bedfe05b84e852cd9c1587cd381669663073967f42be894a535ba239013f304ce544c3b15a6477c01
DIST cJSON-1.7.15.tar.gz 352278 BLAKE2B e0de3b8d56020853d56f5512e6e7216adafd238b6f69bbf6965b153bfe8ebfc23593dfa7cfb8543d8730d90820153d263c8af276c8e9588ba8a5ad76a50f8b72 SHA512 0b32a758c597fcc90c8ed0af493c9bccd611b9d4f9a03e87de3f7337bb9a28990b810befd44bc321a0cb42cbcd0b026d45761f9bab7bd798f920b7b6975fb124
30 changes: 30 additions & 0 deletions dev-libs/cJSON/cJSON-1.7.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION=" Ultralightweight JSON parser in ANSI C"
HOMEPAGE="https://github.com/DaveGamble/cJSON"
SRC_URI="https://github.com/DaveGamble/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

src_prepare() {
cmake_src_prepare

sed -i -e '/-Werror/d' CMakeLists.txt || die
}

src_configure() {
local mycmakeargs=(
-DENABLE_CJSON_TEST=$(usex test)
)

cmake_src_configure
}

0 comments on commit f16b719

Please sign in to comment.