Skip to content

Commit

Permalink
sys-block/tgt: bup 1.0.70
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
prometheanfire committed Jun 1, 2017
1 parent 8ffc39b commit f17d77b
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-block/tgt/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST tgt-1.0.67.tar.gz 296092 SHA256 bf3f68d9314583459328d060942308a909b795146187ab4d4231ac03481fe6c8 SHA512 8ea1096cdf83a31d3b5c10916d8e3c1d90c23b3072a0cc9e8214bb4c230ac08b37264f1460099069d5ff6e56d31fcb2f6cf7291a2305ed685d106ed1898c50bb WHIRLPOOL d51b14dd146045f49d994f0ce8b8a88e23813c76d98f36709f4b125e8f7cc81a9204a0140c7e8fa88db694c974da56af18bdd495da66232217ca07397003d172
DIST tgt-1.0.68.tar.gz 296862 SHA256 ff9000ccd07c648c57c65ef73c5a694f5e3045be69162bfe33e67028f2f5b7bd SHA512 652182aece13dae91c5193b9084c201ca2dd34331917c56e5ab2b7a8fc0653cb843cf67fe9d95bdb01b52f285e395b28323f0eb834a5de80a58876777902d28e WHIRLPOOL eff054e1684f59d831ee32b4158859a885c68c9f080284e3bbf31d8fed21b86e4972a077620ef5276e9e8c4fead264b281f1124f157d45c2fcf9097dbb71b143
DIST tgt-1.0.69.tar.gz 296481 SHA256 07bc89fdbd3e49490ca42047b38c1249610f2be5ee69aa4c12e5dcd3bc63d0fe SHA512 36964b4a95704b3239f5fefaef1b62ceed72569ea8483e8a23a1a6be4f526a9a9a62ea332ca6ccc2728607936ad8ef547d6e6becb9b240e1704fd7e7d8b4cfbf WHIRLPOOL fcb2ce5498a46c590ca1222cf552090b59b99af588d5e768b94280e87ab5c5f56417e17c6d3ea716ed314725ffb5ca2d47acf014a6619fb376fa6b60b8c5e141
DIST tgt-1.0.70.tar.gz 296474 SHA256 632ed2f064652be7533e928834b55b403927ad381456b8089d903fd92a1f8e3d SHA512 fac7acde7cbd12156ea472d1bed20646dfdd5cfe607503bd1437eaeef816ba8114fe2ebd79e33cb083f8e64fee07bfbf66bcfc6b427c21de814e293e9edaeaad WHIRLPOOL b8b60f2c69e6f9199ba93eae98ca96ea2407ef1d3c26567925a9996d6430cd3f8c204630b046b74487b872ccf02729f89d046b263385e32d14b78fcd336d5e4c
65 changes: 65 additions & 0 deletions sys-block/tgt/tgt-1.0.70.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit flag-o-matic toolchain-funcs

MY_TREE="c32043f"

DESCRIPTION="Linux SCSI target framework (tgt)"
HOMEPAGE="http://stgt.sourceforge.net"
SRC_URI="https://github.com/fujita/tgt/tarball/v${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="fcoe fcp ibmvio infiniband rbd"

CDEPEND="dev-perl/Config-General
dev-libs/libxslt
rbd? ( sys-cluster/ceph )
infiniband? (
sys-fabric/libibverbs:=
sys-fabric/librdmacm:=
)"
DEPEND="${CDEPEND}
app-text/docbook-xsl-stylesheets"
RDEPEND="${DEPEND}
dev-libs/libaio
sys-apps/sg3_utils"

S=${WORKDIR}/fujita-tgt-${MY_TREE}

pkg_setup() {
tc-export CC
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.69-sysmacros.patch #580594

sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die

# make sure xml docs are generated before trying to install them
sed -i -e "s@install: @& all @g" doc/Makefile || die
}

src_compile() {
local myconf
use ibmvio && myconf="${myconf} IBMVIO=1"
use infiniband && myconf="${myconf} ISCSI_RDMA=1"
use fcp && myconf="${myconf} FCP=1"
use fcoe && myconf="${myconf} FCOE=1"
use rbd && myconf="${myconf} CEPH_RBD=1"

emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
emake -C doc
}

src_install() {
emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
newinitd "${FILESDIR}"/tgtd.initd tgtd
newconfd "${FILESDIR}"/tgtd.confd tgtd
dodir /etc/tgt
keepdir /etc/tgt
}

0 comments on commit f17d77b

Please sign in to comment.