Skip to content

Commit

Permalink
dev-db/pgrouting: add 3.6.1
Browse files Browse the repository at this point in the history
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Dec 22, 2023
1 parent 1fe9fa6 commit f1a8d19
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/pgrouting/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pgrouting-3.2.1.tar.gz 5940439 BLAKE2B 01f4ec19d4cee9165a5aca946935cf4786a42f943602eca99414b536dec11ffe298f960e11aaa8b747c1b9c1839625ac9d3e7f67f1f606e941c9c738b4970479 SHA512 ead51de138950707008a7ea6b1a18cfe4d8b1885bfe92849464c2714e39f8e43ef3dbebd1c68279987a1321705fe33a598efb463078491d52cb90a8d1a0414c7
DIST pgrouting-3.5.1.tar.gz 3613985 BLAKE2B a0af5d730673b8a9555891998f0c2cf7ff429d48efc5170aa59ae05518deb6be6b898d52f4c9bf6cd24422922a9c27329cead3281db8df7d7c6b679cec7484f2 SHA512 d29871fc55f8bfa1795816c34483dd8b6a02d24f91b111b5848be8cccc4f04916dc76b99c4bb68ccfcb9c0a745e646ec51e0144a3e09c7fb2d16caabb7a62c40
DIST pgrouting-3.6.1.tar.gz 3871417 BLAKE2B 43295bdb949daf736ba04ca0e89f0374ecbb87859ce49f8436f97bac0491aa69fe118426ddfed939163a975299d085187d51bd233051bf79f97bc4500149fdf4 SHA512 278d6d89ea49e9a38c6ae8c52936e52ae5a3508e9d8693182efdc15649b44be7208affea236046bbb67ff373831a82e2985087f890b0faa4c96be4fa6c3e07cf
52 changes: 52 additions & 0 deletions dev-db/pgrouting/pgrouting-3.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

CMAKE_BUILD_TYPE="Release"

POSTGRES_COMPAT=( {11..16} )
POSTGRES_USEDEP="server"

inherit cmake postgres-multi

DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality"
HOMEPAGE="https://pgrouting.org/"
LICENSE="GPL-2 MIT Boost-1.0"

SLOT="0"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
IUSE=""

RDEPEND="${POSTGRES_DEP}
>=dev-db/postgis-2.0
dev-libs/boost
sci-mathematics/cgal
"

DEPEND="${RDEPEND}"
# Needs a running psql instance, doesn't work out of the box
RESTRICT="test"

src_prepare() {
cmake_src_prepare
postgres-multi_src_prepare
}

my_src_configure() {
local mycmakeargs=( -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)" )
cmake_src_configure
}

src_configure() {
postgres-multi_foreach my_src_configure
}

src_compile() {
postgres-multi_foreach cmake_build
}

src_install() {
postgres-multi_foreach cmake_src_install
}

0 comments on commit f1a8d19

Please sign in to comment.