Skip to content

Commit

Permalink
dev-ml/js_of_ocaml: bump to 2.8.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
aballier committed Sep 13, 2016
1 parent f3e76b5 commit f1b551e
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/js_of_ocaml/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST js_of_ocaml-2.8.1.tar.gz 1329825 SHA256 954ed80b3f37e10666e36ffa3c1d846e1913b8c7be9f0af79889f829b1333e1e SHA512 bce4b173c29396ce7f28f12afd3185cdf402150a7390b9f5a21f14f71e72b3e5ae16234ed65e9d7b18ed2c0de524b658495d62d4673dfe3e61d5f0556b5a125c WHIRLPOOL ac66e7fa70e7365dc5a404d95b9f14186d727756df3aaebfa5d433237d33cb1f070ad74db12136b2a2b2db75b3eac127729343838f361000f962f2a5bc309d79
DIST js_of_ocaml-2.8.2.tar.gz 1334891 SHA256 93d55c7a4883783acb3eee4c6a126993f548f1467d1f08a8d72fa30385a673c4 SHA512 07550311b53a54ec55b5b1e63acbf8eee4757d643cf9639efb035faa029cde4b47c46d732dd2fa3ec0606edf1ef094d096a375c694b0b7255ada16e0c632c4ed WHIRLPOOL 6eac8dccd5217aaa91dc3f899a6ec949afff725dcd1d60276660b0c2e4ca71faf2d55c0a747a3cab05ca55cf7962aa4dbcd2679ec4f8639c7ccbdf414a105d56
66 changes: 66 additions & 0 deletions dev-ml/js_of_ocaml/js_of_ocaml-2.8.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit findlib eutils

DESCRIPTION="A compiler from OCaml bytecode to javascript"
HOMEPAGE="http://ocsigen.org/js_of_ocaml/"

if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
SRC_URI=""
EGIT_REPO_URI="https://github.com/ocsigen/js_of_ocaml"
KEYWORDS=""
else
SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
IUSE="+async +ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"

RDEPEND="
>=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
>=dev-ml/lwt-2.4.4:=
async? ( dev-ml/async_kernel:= )
react? ( dev-ml/react:= dev-ml/reactiveData:= )
xml? ( >=dev-ml/tyxml-4:= )
ppx? ( dev-ml/ppx_tools:= )
ppx-deriving? ( dev-ml/ppx_deriving:= )
dev-ml/cmdliner:=
dev-ml/menhir:=
dev-ml/ocaml-base64:=
dev-ml/camlp4:=
dev-ml/cppo:=
dev-ml/uchar:=
deriving? ( >=dev-ml/deriving-0.6:= )"
DEPEND="${RDEPEND}
dev-ml/ocamlbuild"

src_configure() {
printf "\n\n" >> Makefile.conf
use ocamlopt || echo "BEST := byte" >> Makefile.conf
use ocamlopt || echo "NATDYNLINK := NO" >> Makefile.conf
use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
use react || echo "WITH_REACT := NO" >> Makefile.conf
use ppx || echo "WITH_PPX := NO" >> Makefile.conf
use ppx-deriving || echo "WITH_PPX_PPX_DERIVING := NO" >> Makefile.conf
use async || echo "WITH_ASYNC := NO" >> Makefile.conf
}

src_compile() {
emake -j1
use doc && emake doc
}

src_install() {
findlib_src_preinst
emake BINDIR="${ED}/usr/bin/" install
dodoc CHANGES README.md
use doc && dohtml -r doc/api/html/
}

0 comments on commit f1b551e

Please sign in to comment.