Skip to content

Commit

Permalink
dev-lang/eisl: bump to 3.03
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Jun 25, 2023
1 parent 4ebc476 commit f1caca6
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/eisl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST eisl-2.93.tar.gz 2138623 BLAKE2B 049628a3dba0b9da5334bb575e7cfd977cdee6b08f009590c3dd13ba81e325ef4cf9d64c8a3fc7b59b9459e5dca0f7d49243b61040d662200a3b64f797d631fe SHA512 261ca84594f6fa408739e3aedb0f0c0b0d246df14b6b79a3efb013219730b93290e725eb976980ac23488c361bca05eb642d3b4fc408ee4355ba84ca658185e7
DIST eisl-2.98.tar.gz 2143636 BLAKE2B e38bf59e491218602e24217903b0f656ebcdee29311ec988447bff58b92f3bc51aa671ba8daf304fa8ce05a45ba71e22839bf74cfc6b1cc704e4c2bd1b5e1a74 SHA512 611bae543c4b12c3b7fb43a660edd219e9d8c1211ce6e3d7d19beae3ac5863f4f20722b79865444a42da30a0210474616115432428a2341b79e20b59e4a3a6e4
DIST eisl-3.00.tar.gz 2143246 BLAKE2B b4a5fd7590f2016cab539603780a6717ce6a26c07230334e5a5cef6b27f72360c33c85f3ed0d2163b9db331f1a2ae4ca4f062728c1669ecf07edcd287914aa76 SHA512 fbc59a1585993e03a1e6388537cd8efe4f1497e6ba0ff08b13fbfd554d900a20a6be36f217baa94cd34bd2eb9a46b406d162306301491412c20b6097759fd796
DIST eisl-3.03.tar.gz 2146686 BLAKE2B 540e51007ad0db3271c13e4bf8804f1d555a8baea19da3f66075a57abe77d71560c6d634eded1c86cda054327c01415a46e36fd67ea233553745ad49100dbd8c SHA512 b800073db94a394ef131db38744197b7273eb64a0125e4ccfb982de618a0f5ec5d031e632acb74efbb678bf200ae4e9b81bd5dce24ed4ba02764aa97d86ec878
46 changes: 46 additions & 0 deletions dev-lang/eisl/eisl-3.03.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"

if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
else
SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="BSD-2"
SLOT="0"
RESTRICT="test" # Tests run cppcheck (and fail)

DOCS=( README{,-ja}.md documents )

RDEPEND="sys-libs/ncurses:="
DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}"/${PN}-2.85-Makefile.patch )

src_compile() {
emake CC="$(tc-getCC)" clean edlis eisl
}

src_install() {
exeinto /usr/bin
doexe edlis eisl

# Compilation of ISLisp files on installation fails.
# Do not compile them and mimic "make install".
insinto /usr/share/${PN}
doins -r library
doins fast.h ffi.h

einstalldocs
}

0 comments on commit f1caca6

Please sign in to comment.