Skip to content

Commit

Permalink
dev-util/ltrace: fix print-instruction-pointer test
Browse files Browse the repository at this point in the history
print-instruction-pointer occasionally fails when
kernel loads test at address that does not match
last 4 digits of 'objdump' output.

On x86_64 page size is 4096 bytes (0x1000). This gives
only 3 digits of stable address.

The change picks last 3 digits from objdump address.

Signed-off-by: Sergei Trofimovich <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
Sergei Trofimovich committed Oct 4, 2018
1 parent 395ed52 commit f1e6f16
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 1 deletion.
15 changes: 15 additions & 0 deletions dev-util/ltrace/files/ltrace-0.7.3-print-test-pie.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
--- a/testsuite/ltrace.minor/print-instruction-pointer.exp
+++ b/testsuite/ltrace.minor/print-instruction-pointer.exp
@@ -32,6 +32,12 @@ catch "exec sh -c {objdump -d $objdir/$subdir/$binfile | sed -n '/^\[0-9a-fA-F\]
catch "exec sh -c {echo \"$output\" | sed -n '2p'| awk -F' ' '{print \$1}'|awk -F: '{print \$1}'}" addr1
catch "exec sh -c {echo \"$output\" | sed -n '5p'| awk -F' ' '{print \$1}'|awk -F: '{print \$1}'}" addr2

+# Pick at most last 3 digits:
+# PIE binaries randomize address on page level.
+# Let's assume page size is no bigger than 4096 (3 hex digits)
+set addr1 [string range $addr1 3 end]
+set addr2 [string range $addr2 3 end]
+
verbose "addr1 = $addr1"
verbose "addr2 = $addr2"
# Verify the output by checking numbers of print in main.ltrace.
3 changes: 2 additions & 1 deletion dev-util/ltrace/ltrace-0.7.3_p4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-0.7.3-test-protos.patch #bug 421649
epatch "${FILESDIR}"/${PN}-0.7.3-alpha-protos.patch
epatch "${FILESDIR}"/${PN}-0.7.3-ia64.patch
epatch "${FILESDIR}"/${PN}-0.7.3-print-test-pie.patch
sed -i '/^dist_doc_DATA/d' Makefile.am || die
eautoreconf
}
Expand Down

0 comments on commit f1e6f16

Please sign in to comment.