forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-kernel/rt-sources: version bump to {3.18.46_p50,4.1.37_p43,4.4.39…
…_p50,4.8.15_p10,4.9.4_p2} and remove old Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
1 parent
48aa099
commit f1e9dc8
Showing
6 changed files
with
153 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...l/rt-sources/rt-sources-4.4.30_p41.ebuild → .../rt-sources/rt-sources-3.18.46_p50.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...nel/rt-sources/rt-sources-4.8.6_p5.ebuild → ...l/rt-sources/rt-sources-4.1.37_p43.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
ETYPE="sources" | ||
KEYWORDS="~amd64" | ||
|
||
HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/" | ||
|
||
inherit versionator | ||
|
||
CKV="$(get_version_component_range 1-3)" | ||
K_SECURITY_UNSUPPORTED="1" | ||
K_DEBLOB_AVAILABLE="1" | ||
RT_PATCHSET="${PV/*_p}" | ||
|
||
inherit kernel-2 | ||
detect_version | ||
|
||
K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}" | ||
RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz" | ||
RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \ | ||
mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}" | ||
|
||
DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch" | ||
SRC_URI="${KERNEL_URI} ${RT_URI}" | ||
|
||
KV_FULL="${PVR/_p/-rt}" | ||
S="${WORKDIR}/linux-${KV_FULL}" | ||
|
||
UNIPATCH_LIST="${DISTDIR}/${RT_FILE}" | ||
UNIPATCH_STRICTORDER="yes" | ||
|
||
pkg_postinst() { | ||
|
||
ewarn | ||
ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way." | ||
ewarn "If you need support, please contact the RT project developers directly." | ||
ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with" | ||
ewarn "the ebuilds." | ||
ewarn | ||
} | ||
|
||
K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \ | ||
${HOMEPAGE}." |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
ETYPE="sources" | ||
KEYWORDS="~amd64" | ||
|
||
HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/" | ||
|
||
inherit versionator | ||
|
||
CKV="$(get_version_component_range 1-3)" | ||
K_SECURITY_UNSUPPORTED="1" | ||
K_DEBLOB_AVAILABLE="1" | ||
RT_PATCHSET="${PV/*_p}" | ||
|
||
inherit kernel-2 | ||
detect_version | ||
|
||
K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}" | ||
RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz" | ||
RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \ | ||
mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}" | ||
|
||
DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch" | ||
SRC_URI="${KERNEL_URI} ${RT_URI}" | ||
|
||
KV_FULL="${PVR/_p/-rt}" | ||
S="${WORKDIR}/linux-${KV_FULL}" | ||
|
||
UNIPATCH_LIST="${DISTDIR}/${RT_FILE}" | ||
UNIPATCH_STRICTORDER="yes" | ||
|
||
pkg_postinst() { | ||
|
||
ewarn | ||
ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way." | ||
ewarn "If you need support, please contact the RT project developers directly." | ||
ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with" | ||
ewarn "the ebuilds." | ||
ewarn | ||
} | ||
|
||
K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \ | ||
${HOMEPAGE}." |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
ETYPE="sources" | ||
KEYWORDS="~amd64" | ||
|
||
HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/" | ||
|
||
inherit versionator | ||
|
||
CKV="$(get_version_component_range 1-3)" | ||
K_SECURITY_UNSUPPORTED="1" | ||
K_DEBLOB_AVAILABLE="1" | ||
RT_PATCHSET="${PV/*_p}" | ||
|
||
inherit kernel-2 | ||
detect_version | ||
|
||
K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}" | ||
RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz" | ||
RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \ | ||
mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}" | ||
|
||
DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch" | ||
SRC_URI="${KERNEL_URI} ${RT_URI}" | ||
|
||
KV_FULL="${PVR/_p/-rt}" | ||
S="${WORKDIR}/linux-${KV_FULL}" | ||
|
||
UNIPATCH_LIST="${DISTDIR}/${RT_FILE}" | ||
UNIPATCH_STRICTORDER="yes" | ||
|
||
pkg_postinst() { | ||
|
||
ewarn | ||
ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way." | ||
ewarn "If you need support, please contact the RT project developers directly." | ||
ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with" | ||
ewarn "the ebuilds." | ||
ewarn | ||
} | ||
|
||
K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \ | ||
${HOMEPAGE}." |