Skip to content

Commit

Permalink
media-video/dvdstyler: bump to 3.0.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
aballier committed Jan 13, 2018
1 parent d79fcb2 commit f1f6e66
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/dvdstyler/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST DVDStyler-3.0.3.tar.bz2 8850630 BLAKE2B 1fac6687bad0c80728894f1a19ef823d3ba4ea5b648e8e9b6e1b4c98c5d12a353a1bda0499d612ab508ccae16e773c04af6781e189fb09e9799001074d6f7b66 SHA512 b5e5a93d127bc45b844cadce036b2d70ede5b3ea9d5fd026a93d6a6813684873db41ca0d4cd15680e63a63f2ba4314f65c2a0c08e44d0b4bbcce703874c2c3ed
DIST DVDStyler-3.0.4.tar.bz2 8870498 BLAKE2B c1ec7651d90613cebbd8d4e62b4626b8a7e2069eadc07bfe9a91e51bf33638135ca975f4857242b3f9ff34606a4e6084200059c82ebc3aa146f446f9b77483ae SHA512 2747e6a494d331b6f35405d7d2ed47789f4452bb3d4e86b0c68cf0fafffb4e6de452b28fac0e9995c312017c7e4e8a3f89ad42bf0a0c99ce19c5d6c0ca6e351a
72 changes: 72 additions & 0 deletions media-video/dvdstyler/dvdstyler-3.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

MY_P=${P/dvds/DVDS}
WX_GTK_VER=3.0

inherit wxwidgets eutils

DESCRIPTION="A cross-platform free DVD authoring application"
HOMEPAGE="http://www.dvdstyler.org/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug libav +udev"

COMMON_DEPEND="
>=app-cdr/dvd+rw-tools-7.1
media-libs/libexif:=
>=media-libs/wxsvg-1.5.11:=
>=media-video/dvdauthor-0.7.1
>=media-video/xine-ui-0.99.7
virtual/cdrtools
libav? ( >=media-video/libav-9:0=[encode] )
!libav? ( >=media-video/ffmpeg-2.6:0=[encode] )
virtual/jpeg:0
x11-libs/wxGTK:${WX_GTK_VER}=[gstreamer,X]
sys-apps/dbus
udev? ( >=virtual/libudev-215:= )
"
RDEPEND="${COMMON_DEPEND}
>=app-cdr/dvdisaster-0.72.4
media-video/mjpegtools
"
DEPEND="${COMMON_DEPEND}
app-arch/zip
app-text/xmlto
sys-devel/gettext
virtual/yacc
virtual/pkgconfig
"

S="${WORKDIR}/${MY_P}"

src_prepare() {
need-wxwidgets unicode
# disable obsolete GNOME 2.x libraries wrt #508854
sed -i -e '/PKG_CONFIG/s:libgnomeui-2.0:dIsAbLeAuToMaGiC&:' configure || die
# rmdir: failed to remove `tempfoobar': Directory not empty
sed -i -e '/rmdir "$$t"/d' docs/Makefile.in || die
# fix underlinking wrt #367863
sed -i -e 's:@LIBS@:& -ljpeg:' wxVillaLib/Makefile.in || die
# silence desktop-file-validate QA check
sed -i \
-e '/Icon/s:.png::' -e '/^Encoding/d' -e '/Categories/s:Application;::' \
data/dvdstyler.desktop || die
}

src_configure() {
econf \
--docdir=/usr/share/doc/${PF} \
$(use_enable debug) \
--with-wx-config=${WX_CONFIG}
}

src_install() {
default
rm -f "${ED}"/usr/share/doc/${PF}/{COPYING*,INSTALL*}
}

0 comments on commit f1f6e66

Please sign in to comment.