Skip to content

Commit

Permalink
games-strategy/wesnoth: bump up to 1.14.13
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/731794
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Jack Todaro <[email protected]>
Closes: gentoo#16631
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
solpeth authored and Lars Wendler committed Jul 8, 2020
1 parent 259b865 commit f234e45
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-strategy/wesnoth/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST wesnoth-1.14.11.tar.gz 500178610 BLAKE2B 27af594bc86845eedb8cd8e45c814c3583e35bd94942947f91b6fa888018ae203dbd100e01ab26b5cd59712895151049105ff446d8ad3a8b2d86133d913a92cc SHA512 3c878f679e51d3657dd4d76205bdeadd6a1a95d0771cd7ab0e29f33f36e32f1963e4a96f4529dbc4b860183b3cb5a4219e86108e0e26194b8a32d3d08a5fd469
DIST wesnoth-1.14.13.tar.gz 502959933 BLAKE2B 48f2e4340e9ae015c2e45f75f419ddfbb95a436a4ffbebbe417fdcf322e162ed0ad799680757adb88e19cba717cc48ec0e3d83c4c170e3502fea7be73a39a0c7 SHA512 ee1b7a93e2ae49698ec185cf6385cd93a49116315ebdec474bd5d5b73ab6af59db92ee5621fab68581edd81c74d8584237d5068fd30362054377d84a3dcb5ea0
DIST wesnoth-1.14.9.tar.gz 497393449 BLAKE2B b5235de6ce84164ef97a105339549a8a1009d7b7ed243ae355994610e56afc584b8a37b1275e0b929729a24cd2eb94d4c208e7bd22e79b76113a1e1b91c8f92d SHA512 b3e93956a40ffc48dd02e118be1d46854a2eed34ad0dca3fb34a28d0b58b4b563cb5cca588208f3525300bf075786bebe95a25c045c8098a0bdfe531a2d81e4f
DIST wesnoth-1.15.3.tar.gz 495645949 BLAKE2B aa6b8636ff1b134af5e6e9cfbefefee3189a46ccd20c2a3a3f361d77d3de48d1ae38bf8376087b6292bcacc465ad72bd60ab7aa16b3ca536ce963b6f644b8ff1 SHA512 2a5993c2c2f41939346f88104722e31a1bd0f68b39c84bdf657a7156c1348e6c65089e2766c088a2b5a2c2df8c3cd8c5cf736d66538c87cf175585634e31adbb
111 changes: 111 additions & 0 deletions games-strategy/wesnoth/wesnoth-1.14.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake flag-o-matic toolchain-funcs xdg

DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
https://github.com/wesnoth/wesnoth"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
# uneven minor versions are development versions
if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
KEYWORDS="~amd64 ~x86"
fi
IUSE="dbus dedicated doc fribidi libressl nls server"

RDEPEND="
acct-group/wesnoth
acct-user/wesnoth
>=dev-libs/boost-1.50:=[nls,threads,icu]
>=media-libs/libsdl2-2.0.4:0[joystick,video,X]
!dedicated? (
dev-libs/glib:2
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
>=media-libs/fontconfig-2.4.1
>=media-libs/sdl2-image-2.0.0[jpeg,png]
>=media-libs/sdl2-mixer-2.0.0[vorbis]
>=media-libs/sdl2-ttf-2.0.12
media-libs/libvorbis
>=x11-libs/pango-1.22.0
>=x11-libs/cairo-1.10.0
sys-libs/readline:0=
dbus? ( sys-apps/dbus )
fribidi? ( dev-libs/fribidi )
)"
DEPEND="${RDEPEND}
x11-libs/libX11
"
BDEPEND="
sys-devel/gettext
virtual/pkgconfig
"

src_prepare() {
cmake_src_prepare

if ! use doc ; then
sed -i \
-e '/manual/d' \
doc/CMakeLists.txt || die
fi

# respect LINGUAS (bug #483316)
if [[ ${LINGUAS+set} ]] ; then
local lang langs=()
for lang in $(cat po/LINGUAS) ; do
has ${lang} ${LINGUAS} && langs+=( ${lang} )
done
echo "${langs[@]}" > po/LINGUAS || die
fi
}

src_configure() {
filter-flags -ftracer -fomit-frame-pointer
if [[ $(gcc-major-version) -eq 3 ]] ; then
filter-flags -fstack-protector
append-flags -fno-stack-protector
fi

# Work around eclass
append-flags -UNDEBUG

if use dedicated || use server ; then
mycmakeargs=(
-DENABLE_CAMPAIGN_SERVER="ON"
-DENABLE_SERVER="ON"
-DSERVER_UID="${PN}"
-DSERVER_GID="${PN}"
-DFIFO_DIR="/run/wesnothd"
)
else
mycmakeargs=(
-DENABLE_CAMPAIGN_SERVER="OFF"
-DENABLE_SERVER="OFF"
)
fi
mycmakeargs+=(
-Wno-dev
-DENABLE_GAME="$(usex !dedicated)"
-DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
-DENABLE_NLS="$(usex nls)"
-DENABLE_NOTIFICATIONS="$(usex dbus)"
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_STRICT_COMPILATION="OFF"
)
cmake_src_configure
}

src_install() {
local DOCS=( README.md changelog.md )
cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
fi
}

0 comments on commit f234e45

Please sign in to comment.