Skip to content

Commit

Permalink
app-misc/note: bump to 1.3.26
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 10, 2021
1 parent 5b200d8 commit f26e630
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/note/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST note-1.3.26.tar.gz 53485 BLAKE2B b88fe67b708d85a60ea705caa99506a5ef59c442ed233b349cb07bf1cbc80514e8324b63f6e7a1ea6727e9742b11ecf4c460ecda818fc03de4532a132e3aa608 SHA512 4de22da10aef93e694cd1facb356666241435d2a468c25d43f42453c708d9a75b451820a01d952e587cca34b310a64c6e0069cdbe264376eb0cf50e3f852a252
DIST note-1.3.3.tar.gz 42691 BLAKE2B f4dc9b5c006925c04706260ed0d11f1c5bfb0923786284401c1f824936a32b61a60e516b35070cb4dcd8302caec820aad37e02c31c5fd50a8931d4cba54ef5ad SHA512 99744394084eec3bf84ecef10b2bc294375f18f6ce41614316c4f4bc02a73297f4b3a956f48fb424bb0b0f100ea23debea49c1029887ca52043dd733de0fcfad
66 changes: 66 additions & 0 deletions app-misc/note/note-1.3.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit perl-module

DESCRIPTION="A note taking perl program"
HOMEPAGE="https://www.daemon.de/NOTE"
SRC_URI="https://www.daemon.de/idisk/Apps/note/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="crypt dbm general mysql text"

DEPEND="
dev-perl/Config-General
dev-perl/TermReadKey
dev-perl/Term-ReadLine-Perl
dev-perl/YAML
virtual/perl-Storable
crypt? (
dev-perl/Crypt-CBC
dev-perl/Crypt-Blowfish
dev-perl/Crypt-DES
)
mysql? ( dev-perl/DBD-mysql )
"
RDEPEND="${DEPEND}"

# extraneous README that gets installed into the perl module
PERL_RM_FILES=( NOTEDB/README )

src_prepare() {
# Supressing file not needed
local v
for v in mysql text dbm general; do
if ! use ${v}; then
PERL_RM_FILES+=( NOTEDB/${v}.pm )
fi
done
perl-module_src_prepare
}

src_install() {
perl-module_src_install

# Adding some basic utitily for testing note
exeinto /usr/share/${PN}
doexe bin/stresstest.sh

# Adding some help for mysql backend driver
if use mysql; then
insinto /usr/share/${PN}/mysql
exeinto /usr/share/${PN}/mysql
doins mysql/{README,sql,permissions}
doexe mysql/install.sh
fi

# Adding a sample configuration file
insinto /etc
doins config/noterc

dodoc UPGRADE VERSION
}

0 comments on commit f26e630

Please sign in to comment.