Skip to content

Commit

Permalink
dev-python/pythonfinder: Bump to 2.0.6
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 14, 2023

Verified

This commit was signed with the committer’s verified signature. The key has expired.
mgorny Michał Górny
1 parent 24db692 commit f2c599f
Showing 3 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pythonfinder/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pythonfinder-2.0.5.tar.gz 718776 BLAKE2B 32a49dbff143042554d5328b61b612e3bde7a870d53a229303b6bdd2c2ce76457bf6aadcdb215efa332407003c1319215292f3278a2808b669b5b7819af08902 SHA512 4d205c66d7ae36f4f2b8ddab9cce00f4efd5548a41d251470a515b88f8be2dcede75372b9301223822031ae663c6ccf77156531b0dd5d8972424f90641255c5b
DIST pythonfinder-2.0.6.tar.gz 718821 BLAKE2B bc45c8ebffd4b8a21084c3b5f4d9cba71383613e6b25ec01ba53b0abf5d01cf78d1636b19c6c32f80eec401c56c25eedded793fabc46e2bbd389074a45ae14f5 SHA512 2aad884101d1a9fc1340fb63b11811aa7bd1c1f6d2945f9d133bb473099c7e11da21a4348ca742cae03a23fc8b12b85dcae4e9b3a2d29ec98530b6d8d2567d1c
38 changes: 38 additions & 0 deletions dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
diff --git a/pyproject.toml b/pyproject.toml
index 73a3c85..27c9a7e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39 +39 @@ dependencies = [
- "pydantic>=1.10.7,<2",
+ "pydantic>=2",
@@ -140 +140 @@ runtime-evaluated-base-classes = [
- "pydantic.BaseModel",
+ "pydantic.v1.BaseModel",
diff --git a/src/pythonfinder/models/common.py b/src/pythonfinder/models/common.py
index 4c439c9..0ef3d77 100644
--- a/src/pythonfinder/models/common.py
+++ b/src/pythonfinder/models/common.py
@@ -3 +3 @@ from __future__ import annotations
-from pydantic import BaseModel, Extra
+from pydantic.v1 import BaseModel, Extra
diff --git a/src/pythonfinder/models/mixins.py b/src/pythonfinder/models/mixins.py
index 58ce99a..e68020f 100644
--- a/src/pythonfinder/models/mixins.py
+++ b/src/pythonfinder/models/mixins.py
@@ -15 +15 @@ from typing import (
-from pydantic import BaseModel, Field, validator
+from pydantic.v1 import BaseModel, Field, validator
diff --git a/src/pythonfinder/models/path.py b/src/pythonfinder/models/path.py
index fe98054..beb88be 100644
--- a/src/pythonfinder/models/path.py
+++ b/src/pythonfinder/models/path.py
@@ -26 +26 @@ else:
-from pydantic import Field, root_validator
+from pydantic.v1 import Field, root_validator
diff --git a/src/pythonfinder/models/python.py b/src/pythonfinder/models/python.py
index c5e0345..32c82a8 100644
--- a/src/pythonfinder/models/python.py
+++ b/src/pythonfinder/models/python.py
@@ -22 +22 @@ from packaging.version import Version
-from pydantic import Field, validator
+from pydantic.v1 import Field, validator
35 changes: 35 additions & 0 deletions dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..12} )

inherit distutils-r1 pypi

DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
HOMEPAGE="
https://github.com/sarugaku/pythonfinder/
https://pypi.org/project/pythonfinder/
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
>=dev-python/pydantic-2[${PYTHON_USEDEP}]
"

distutils_enable_tests pytest

PATCHES=(
# based on the patch from Arch
# https://gitlab.archlinux.org/archlinux/packaging/packages/python-pythonfinder/-/blob/main/python-pythonfinder-2.0.5-pydantic2.patch
"${FILESDIR}"/pythonfinder-2.0.6-pydantic-2.patch
)

python_test() {
epytest -o addopts=
}

0 comments on commit f2c599f

Please sign in to comment.