Skip to content

Commit

Permalink
dev-python/m2crypto: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
patricklauer committed Oct 20, 2016
1 parent c439a2b commit f30d1a5
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/m2crypto/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST M2Crypto-0.22.3.tar.gz 74795 SHA256 6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72 SHA512 c179d3cf03ced77aed24285ca3f1527d5e05bbfe091a1522bff94a940fd390213fbb9b83d7ccd43ceae49626b427ae8790782cf93ead85be1e063bc4121c62e0 WHIRLPOOL 66a9a6e7c9b195814048a1bcecf6ef71a269bebb9dbda73801c88b3ba27330b555a46d05c53bbd0778f9c1e1bb5f9c6e7e860de443bf16baffc2072ee5996e31
DIST M2Crypto-0.23.0.tar.gz 183590 SHA256 1ac3b6eafa5ff7e2a0796675316d7569b28aada45a7ab74042ad089d15a9567f SHA512 b1c57328c60cb82fdc196c491d9518d58a996fbae35e32b0bd20d3d38ec8f72d0981ba7dde154f7684224ce9ee38e69460328f1bd8931b16210233c8199e6c51 WHIRLPOOL a618c294e59ede845cec02cc28146fa05b8ac68959e10c19eb2d6b97b113cf87620d89226ff9453f66fc7f4592e7a106ddf75b946cd4042f754c0c6dd9759fbd
DIST M2Crypto-0.24.0.tar.gz 184457 SHA256 80a56441a1d2c0cf27e725be7554c92598b938fc8767ee2c71fdbc2fdc055ee8 SHA512 c23ae0f8ac790d4ef108a217a44e994341f6bbe4e12a7fef2518d8def82331246a145e19a2504b82b790a3ad4b467d2facc8a73bb7f1190b56441d8482c66aca WHIRLPOOL 47a437ee1207b4cca8d67aa4bdec95b9194030e3fc7146ace8d071caa9be829f3e9516ff9399e695615acdf930a90040deb0f1175d81994465ed0853688e3b37
DIST M2Crypto-0.25.1.tar.gz 300904 SHA256 ac303a1881307a51c85ee8b1d87844d9866ee823b4fdbc52f7e79187c2d9acef SHA512 096d414efd5558f9ca4cebf46a297fa39f799e35c4325e031ee816689345e041370f2129650a10db66ebfcfe64309a7c7b49082306567baaf003b88ed9d60bda WHIRLPOOL c634685f8e096c41fc6caf9b364c5393b8f62fb585cd63f7599bb9cc10f910eb25cf48772616773ad9708d1f0fc25f139ee897d925d18432a03e18db552bfe7b
39 changes: 39 additions & 0 deletions dev-python/m2crypto/m2crypto-0.25.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

MY_PN="M2Crypto"

DESCRIPTION="M2Crypto: A Python crypto and SSL toolkit"
HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.python.org/pypi/M2Crypto"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="libressl"

RDEPEND="
!libressl? ( >=dev-libs/openssl-0.9.8:0= )
libressl? ( dev-libs/libressl:= )
"
DEPEND="${RDEPEND}
>=dev-lang/swig-1.3.28:0
dev-python/setuptools[${PYTHON_USEDEP}]
"

S="${WORKDIR}/${MY_PN}-${PV}"

# Tests access network, and fail randomly. Bug #431458.
RESTRICT=test

python_test() {
esetup.py test
}

0 comments on commit f30d1a5

Please sign in to comment.