Skip to content

Commit

Permalink
sci-libs/hipFFT: use HIP config.
Browse files Browse the repository at this point in the history
hipFFT is not updated in 5.7.1, and we need to manually backport it.

Reference: ROCm/hipFFT#66
Signed-off-by: Benda Xu <[email protected]>
  • Loading branch information
heroxbd committed Nov 20, 2023
1 parent ec2fa22 commit f30f416
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
40 changes: 40 additions & 0 deletions sci-libs/hipFFT/files/hipFFT-5.7.1_hip-config.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
From c2b06a3b49257b3f89cf203895cf370e64e47b27 Mon Sep 17 00:00:00 2001
From: trixirt <[email protected]>
Date: Mon, 31 Jul 2023 09:50:19 -0700
Subject: [PATCH] Simplify finding the hip package

On Fedora, where hip is installed as an rpm, its cmake files can
not be found and are reported as an error.

CMake Error at cmake/dependencies.cmake:44 (find_package):
No "FindHIP.cmake" found in CMAKE_MODULE_PATH.

This change treats hip as a normal package.

Signed-off-by: Tom Rix <[email protected]>
---
cmake/dependencies.cmake | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
index 262478d..5810e37 100644
--- a/cmake/dependencies.cmake
+++ b/cmake/dependencies.cmake
@@ -30,7 +30,7 @@ if( NOT CMAKE_CXX_COMPILER MATCHES ".*/hipcc$" )
if( WIN32 )
find_package( HIP CONFIG REQUIRED )
else()
- find_package( HIP MODULE REQUIRED )
+ find_package( HIP REQUIRED )
endif()
list( APPEND HIP_INCLUDE_DIRS "${HIP_ROOT_DIR}/include" )
endif()
@@ -41,7 +41,7 @@ else()
if( WIN32 )
find_package( HIP CONFIG REQUIRED )
else()
- find_package( HIP MODULE REQUIRED )
+ find_package( HIP REQUIRED )
endif()
endif()
endif()
1 change: 1 addition & 0 deletions sci-libs/hipFFT/hipFFT-5.7.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -28,6 +28,7 @@ S="${WORKDIR}/hipFFT-rocm-${PV}"
PATCHES=(
"${FILESDIR}/${PN}-5.0.2-remove-git-dependency.patch"
"${FILESDIR}/${PN}-4.3.0-add-complex-header.patch"
"${FILESDIR}/${PN}-5.7.1_hip-config.patch"
)

src_configure() {
Expand Down

0 comments on commit f30f416

Please sign in to comment.