forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gui-libs/xdg-desktop-portal-lxqt: add 0.5.0
Signed-off-by: Jimi Huotari <[email protected]>
- Loading branch information
Showing
2 changed files
with
36 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST xdg-desktop-portal-lxqt-0.4.0.tar.xz 16024 BLAKE2B 2f362f9ddff42d68dfe69bcebd229566fe396a5a14d9ee9f1650706a34a98f31291a9901ef7121a976c679481192959d785ca8c8401bf8b2839dd18e42eee6bc SHA512 9295da6dc9370e01a48729848d9d19c9afea980335fb1cefeb91abf34b12d53579d876ccc952e2ef1440e10f0937b9c4a02d2c8473c9cad812da0388bfcacbe1 | ||
DIST xdg-desktop-portal-lxqt-0.5.0.tar.xz 16044 BLAKE2B f4b872038c58eebe3c565f55d29e24f9b247d2a18fd60981df9546a7fab422aa9ae1f6e94608a99a091cda4bda1e5ce878fa4d997a457f7c2014191fd631a0d2 SHA512 3f1a0de1fcc577b14b69c98b715f627dc636edc8663786374627196873a6e123aab2b6051bd86416729eb6e101ec0625051716b981a3fc4d7b5c7ddcd46ceae8 |
35 changes: 35 additions & 0 deletions
35
gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.5.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 2022-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
MY_PV="$(ver_cut 1-2)" | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt" | ||
HOMEPAGE="https://lxqt-project.org/" | ||
|
||
if [[ "${PV}" == "9999" ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git" | ||
else | ||
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz" | ||
KEYWORDS="~amd64" | ||
fi | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
|
||
BDEPEND=">=dev-util/lxqt-build-tools-0.13.0" | ||
DEPEND=" | ||
dev-qt/qtcore:5 | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtwidgets:5 | ||
kde-frameworks/kwindowsystem:5 | ||
>=x11-libs/libfm-qt-1.4:= | ||
" | ||
RDEPEND="${DEPEND} | ||
sys-apps/xdg-desktop-portal | ||
" |