forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
Jeroen Roovers
committed
Nov 18, 2017
1 parent
2c89474
commit f3369d4
Showing
2 changed files
with
74 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST debhelper_10.10.3.tar.xz 428548 SHA256 54a381b7bf70f5fa22afe33ccddb13785f26661f03b3ff8b98b7c2e50eb81902 SHA512 b1e78b4894285070f08833a84837ef1cbd8da6cfb04f43538944b9bfb7b9f56e9fe1f9f6ece42c1b4bc2abc6e421c68e42e2517f1d45f90511d213f690a6409d WHIRLPOOL d77bbafaca4b6c7d1752e174d078a03de6541536b15a9d2cf1f176f98836282b777b371c585f301b422b5b049e5615ffda0c6a0222bc2c91ca78c6a77b317481 | ||
DIST debhelper_10.10.5.tar.xz 429752 SHA256 930cb5bd922149e797a2b90c7bec55bf8c819b275698abdf52d8290bafd801c5 SHA512 0bd4310318f85039326b516ba854193b72d850b9e11661233b401c7ba45be3137ee67d1c894b227a8432de025a62e9b176dd5dcb194c739f29007d9e73b32448 WHIRLPOOL 13de9aca3d49bcef498bf7af05dca0f0f10908249d1cbfd960e0158afa4d83072e16dd3d11b3590d12111376b6fc82963864eaba8b52460ef2f883107c285c7a | ||
DIST debhelper_10.10.8.tar.xz 430984 SHA256 a5437bd0629233aeb14133b387506b37c5dc4a3098cc22f8a5d519eca0fb76c1 SHA512 90f03a354647e55614b2f13b869525a4800fd347cce2ed370be9e8591219c353170d04dcf976c52d64194321410cc4fbdb042166145479ee4bae833009d44100 WHIRLPOOL 859ba205c6e6b1fd4fc7d647f5579bab3ee81d1b89d09d76f17686e2bb15f002daab0146ddf9b7bd886795ce5ef52d8ce5dee0f1e53d14a93e84615946ab04f9 | ||
DIST debhelper_9.20160814.tar.xz 344328 SHA256 2834a7c1dbeafd9402ea68948c815dab19d903503c45fd70e676269fccd359c0 SHA512 63072ba35ec8c62ee4c4d44833712925264c808a91f1522ef6a73377f2da3d11b285a21ad39158fd44693c801916189261186c8c7b28096719328a81a0a65f62 WHIRLPOOL 334f0aa8075896ec13a061b9841adb5f2b7c5fa6996b507785f50389c86c48e3c89a84ff1049ae7d7cbe4876b649010f892f54f1074ecafd76061bf0588e65d6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit eutils toolchain-funcs | ||
|
||
DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules" | ||
HOMEPAGE="https://packages.qa.debian.org/d/debhelper.html" | ||
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux" | ||
IUSE="test" | ||
DH_LINGUAS=( de es fr ) | ||
IUSE+=" ${DH_LINGUAS[@]/#/linguas_}" | ||
|
||
NLS_DEPEND=$( | ||
printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]} | ||
) | ||
|
||
RDEPEND=" | ||
>=dev-lang/perl-5.10:= | ||
>=app-arch/dpkg-1.17 | ||
dev-perl/TimeDate | ||
virtual/perl-Getopt-Long | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
${NLS_DEPEND} | ||
test? ( | ||
dev-perl/Test-Pod | ||
sys-apps/fakeroot | ||
) | ||
" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
src_compile() { | ||
tc-export CC | ||
|
||
local LANGS="" USE_NLS=no lingua | ||
for lingua in ${DH_LINGUAS[@]}; do | ||
if use linguas_${lingua}; then | ||
LANGS+=" ${lingua}" | ||
USE_NLS=yes | ||
fi | ||
done | ||
|
||
emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install | ||
dodoc doc/* debian/changelog | ||
docinto examples | ||
dodoc examples/* | ||
local lingua | ||
for manfile in *.1 *.7 ; do | ||
for lingua in ${DH_LINGUAS[@]}; do | ||
case ${manfile} in | ||
*.${lingua}.?) | ||
use linguas_${lingua} \ | ||
&& cp ${manfile} "${T}"/${manfile/.${lingua}/} \ | ||
&& doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/} | ||
;; | ||
*) | ||
doman ${manfile} | ||
;; | ||
esac | ||
done | ||
done | ||
} |