forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-db/mycli: Version bump for 1.17.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
- Loading branch information
Brian Evans
committed
Sep 11, 2018
1 parent
e1b7d4c
commit f35e214
Showing
3 changed files
with
59 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mycli-1.10.0.tar.gz 272722 BLAKE2B f2a4d7b76684718167fb6bb4f90a96a31b669cf1f35c266ed544d00b4fe4f9b0cb2c6d81e161d41f1df785e2dcf79056a675857f8400d8cd7811199ea00064b7 SHA512 d66866fd23ee2be3f1bb47d1414b8151c2b50e8844a2553e139f753ae55dd010d1c23aae7c5863891ea4f347b124145405dc7894efc27fc8fcb74127c14261f8 | ||
DIST mycli-1.15.0.tar.gz 275065 BLAKE2B 47ae049a7a669d18fc2bb467dd4ee6d1bbe23a86115db6d1965c48c93a2a1be9bb8b4427b377f8ce935b957c854c1c4bf4a87fdea07f27329a13fd6a28b59559 SHA512 7a7d98220c4a679340dbf3c3c9fb3eaab7698f7abbe3e62835a03df10b59c79f0dfd916e9f7b39f12215063849ecadf9d08d086d14b00666b67bac1d092609f2 | ||
DIST mycli-1.17.0.tar.gz 276786 BLAKE2B 203c54b58a7876fd0bab5a05880621263e5cdf786b13207f04dfaf38866f5a7250e8fe8e1c5870aa9d3f562cf9963f15cc433e3ddd2232531f4c823e46778ac7 SHA512 bd64f44ed7b16a1e9c684da52fa60436876b26333e2705e5226c4fab3a979c6680314447333d01e4fdb274d33a7f093cbb2f732e5b4e04c5330066f9918a35ba | ||
DIST mycli-1.7.1.tar.gz 266597 BLAKE2B 8fc6006dbb85a7053d67040d492ba12619507160efd240fdb89125794a01fbb439756bdeb420c306a883db925f6ec7ae0c36657c4c4b2197cfb702fc77babcb1 SHA512 5c61fe67f3205dd1123ed8d38441cda0574db04dd46b7e075d216f7aa8cd856a2f06a1b4bf7dbe9fd0b07f3e91c151fe3f885d10d3db488b6c306e0ce9ac9e7c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} ) | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting" | ||
|
||
HOMEPAGE="https://www.mycli.net" | ||
SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
LICENSE="BSD MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
RDEPEND=" | ||
>=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}] | ||
>=dev-python/click-4.1[${PYTHON_USEDEP}] | ||
>=dev-python/configobj-5.0.6[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/prompt_toolkit-1.0.10[${PYTHON_USEDEP}] | ||
!>=dev-python/prompt_toolkit-1.1.0 | ||
>=dev-python/pygments-2.0[${PYTHON_USEDEP}] | ||
>=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}] | ||
>=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}] | ||
!>=dev-python/python-sqlparse-0.3.0 | ||
" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/pytest[${PYTHON_USEDEP}] ${RDEPEND} )" | ||
|
||
python_test() { | ||
pytest --capture=sys \ | ||
--showlocals \ | ||
--doctest-modules \ | ||
--doctest-ignore-import-errors \ | ||
--ignore=setup.py \ | ||
--ignore=mycli/magic.py \ | ||
--ignore=mycli/packages/parseutils.py \ | ||
--ignore=test/features | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters