Skip to content

Commit

Permalink
dev-perl/Crypt-OpenSSL-Random: Bump to version 0.150.0
Browse files Browse the repository at this point in the history
- EAPI7
- Ensure CFLAGS passed to make/compiler
- Remove bad tests unconditionally

Upstream:
- Use Crypt::OpenSSL::Guess for finding OpenSSL include path
- fix mingw hints for pkg-config support

Keywords:
- New dependency dev-perl/Crypt-OpenSSL-Guess requires dropping:
    alpha amd64-linux arm{,64} hppa ia64 m68k{,-mint} mips
    ppc{,-aix,-macos,64} s390 sparc{,-solaris,64-solaris}
    x64-{macos,solaris} x86-{linux,macos,solaris}

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Jul 2, 2020
1 parent 59dac6a commit f3680df
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-perl/Crypt-OpenSSL-Random/Crypt-OpenSSL-Random-0.150.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=RURBAN
DIST_VERSION=0.15
inherit perl-module

DESCRIPTION="OpenSSL/LibreSSL pseudo-random number generator access"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libressl"

RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
"
DEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
"
BDEPEND="${RDEPEND}
>=dev-perl/Crypt-OpenSSL-Guess-0.110.0
virtual/perl-ExtUtils-MakeMaker
"
PERL_RM_FILES=(
t/z_kwalitee.t
t/z_manifest.t
t/z_meta.t
t/z_perl_minimum_version.t
t/z_pod-coverage.t
t/z_pod.t
)

mydoc="ToDo"

src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}
1 change: 1 addition & 0 deletions dev-perl/Crypt-OpenSSL-Random/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Crypt-OpenSSL-Random-0.11.tar.gz 15161 BLAKE2B 33c491755f210514361f6d97715dee781a3f1b99879b2357002dc6dfc8e6c63df530cbcc1ceb8da407928aa531d0fbe85f43afab3d86995f0ade6c58f8bbd320 SHA512 c579cb2b586dbabd697a9c7c989a360ed4bd8e9b28d7c93ad99a86bd9bd680a89c3fa77f6315a1105fd41bfdfa18087ca4cd51fb320faad7a6be9b90e3e69b95
DIST Crypt-OpenSSL-Random-0.15.tar.gz 15506 BLAKE2B 4ed167082904f814fb5484e2c95c0ac881530afecf7ff170041261eebcf3f1227ba8cf98b375a0cf2b18376c7f849340f11ae673ff9638a4c5e4f38db995b9b5 SHA512 bba8ce86b97ce2d6271be503efff6e6e0ff60a797282a2b7cb9c6c0592b69cc43344f9738b4790e5fc165a7273ff01e35ada481cf8c4dfde38cb7ad741d97530

0 comments on commit f3680df

Please sign in to comment.