Skip to content

Commit

Permalink
gui-apps/wf-recorder: live ebuild added
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Aisha Tammy <[email protected]>
Closes: gentoo#15919
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
epsilon-0 authored and juippis committed Jun 11, 2020
1 parent 00baa77 commit f37f8e3
Showing 1 changed file with 42 additions and 0 deletions.
42 changes: 42 additions & 0 deletions gui-apps/wf-recorder/wf-recorder-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Screen recorder for wlroots-based compositors"
HOMEPAGE="https://github.com/ammen99/wf-recorder"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
else
SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+man opencl"

DEPEND="
dev-libs/wayland
media-sound/pulseaudio
media-video/ffmpeg[opencl?,pulseaudio,x264]
opencl? ( virtual/opencl )
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
dev-libs/wayland-protocols
man? ( >=app-text/scdoc-1.9.3 )
"

src_configure() {
local emesonargs=(
$(meson_feature man man-pages)
$(meson_feature opencl)
)
meson_src_configure
}

0 comments on commit f37f8e3

Please sign in to comment.