Skip to content

Commit

Permalink
sys-block/fio: bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
robbat2 committed Nov 8, 2016
1 parent 341fc23 commit f3b8303
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-block/fio/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST fio-2.15.tar.bz2 545809 SHA256 60044f92cfbd2f656162864aae309ab88ff5983c2e49f4b9f8271c445852f5bd SHA512 fa3380031e6e0a597eb34e597af91efbc824a3d5753793fdb00cb10e693943e0358afaad9624eb4333e81182c94424a56fbd1d434eeff098dbf2fc4e19167db0 WHIRLPOOL 32215d63a373c88041d90c6d07d87f9b4e6d4070d1b263676a817dc9ddd8cb175cbbc25e8359cec956ea26a39f40c1cb501ba897475f628ce4f6a5502939239e
DIST fio-2.2.10.tar.bz2 497503 SHA256 04b4490c69f82bafeccbab51d33732cfd74e7a54e74eae0d9a2450faf4f1d857 SHA512 6ff71ca78b2ffa40cd9390b3e4f0b6f07db4d50c85f89c4a9e03c7f327153c0fed3eb8b7c44f3a8f8d0b1b35b48ccb5b1aa96a95fdca08581c22b99f2961c7d3 WHIRLPOOL 7bb881ecea82f3ad568d7513af0486494dc657ede69cc4de0f71e7bdf873ccf8f7a58744ab8f1fce8a1c507c3ce0f7e95eb3a7098a01fe041f04cd29a6a4afb7
DIST fio-2.2.13.tar.bz2 503950 SHA256 66a0084c37bd8804d9f7d260d843a9a3bf51561954024d3b32062b9332281924 SHA512 b2adc4fb1b8c71bb909cfc2cfd9e0d25affcacd47908bc6d126625b448c0e964afa7c65fb88cf21662d4b9d07bfbaebbb2fd66b4c4662382ef68aaf8f053bd6d WHIRLPOOL 112af8620a73e907723760fd01caa4c582f7adba5eef5bf51bb6b695c1a15ff812957937cb67dff00b93c3e941df67d751ecf1aca1627722a6084c5494e7f70a
DIST fio-2.2.9.tar.bz2 492404 SHA256 c881d9cf15500bd4436970d0467c356c5c021417131587931ba78845e965bf56 SHA512 e0cd26bb8a760ef5e40ddb73246671c1988f0c0886bd24fa510fcab93fe64d8853f120355f55fa109168c7fae0b081f63278f2233644f5ed20da4e4c3cb3f3fc WHIRLPOOL 4f5ada7f1140c7229fc3173fa0582a4ae7401121768d8dec828dcd42c1c22ec828e9c000c482b155ead4fd75ee15c4d7678fc7c6d18c8fbb9c749e83f87a4881
Expand Down
94 changes: 94 additions & 0 deletions sys-block/fio/fio-2.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

PYTHON_COMPAT=( python2_7 )

inherit eutils python-r1 toolchain-funcs

MY_PV="${PV/_rc/-rc}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="Jens Axboe's Flexible IO tester"
HOMEPAGE="http://brick.kernel.dk/snaps/"
SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE="aio glusterfs gnuplot gtk numa rbd rdma static zlib"

# GTK+:2 does not offer static libaries.
LIB_DEPEND="aio? ( dev-libs/libaio[static-libs(+)] )
glusterfs? ( sys-cluster/glusterfs[static-libs(+)] )
gtk? ( dev-libs/glib:2[static-libs(+)] )
numa? ( sys-process/numactl[static-libs(+)] )
rbd? ( sys-cluster/ceph[static-libs(+)] )
zlib? ( sys-libs/zlib[static-libs(+)] )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
RDEPEND+="
gnuplot? (
sci-visualization/gnuplot
${PYTHON_DEPS}
)"

S="${WORKDIR}/${MY_P}"

src_prepare() {
#epatch "${FILESDIR}"/fio-2.8-sysmacros.patch #580592
epatch "${FILESDIR}"/fio-2.2.13-libmtd.patch
sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
epatch_user

# Many checks don't have configure flags.
sed -i \
-e "s:\<pkg-config\>:$(tc-getPKG_CONFIG):" \
-e '/if compile_prog "" "-lz" "zlib" *; *then/ '"s::if $(usex zlib true false) ; then:" \
-e '/if compile_prog "" "-laio" "libaio" ; then/'"s::if $(usex aio true false) ; then:" \
configure || die
}

src_configure() {
chmod g-w "${T}"
# not a real configure script
set -- \
./configure \
--disable-optimizations \
--extra-cflags="${CFLAGS} ${CPPFLAGS}" \
--cc="$(tc-getCC)" \
$(usex glusterfs '' '--disable-gfapi') \
$(usex gtk '--enable-gfio' '') \
$(usex numa '' '--disable-numa') \
$(usex rbd '' '--disable-rbd') \
$(usex static '--build-static' '')
echo "$@"
"$@" || die 'configure failed'
}

src_compile() {
emake V=1 OPTFLAGS=
}

src_install() {
emake install DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir="${EPREFIX}/usr/share/man"

if use gnuplot ; then
python_replicate_script "${ED}/usr/bin/fio2gnuplot"
else
rm "${ED}"/usr/bin/{fio2gnuplot,fio_generate_plots} || die
rm "${ED}"/usr/share/man/man1/{fio2gnuplot,fio_generate_plots}.1 || die
rm "${ED}"/usr/share/fio/*.gpm || die
rmdir "${ED}"/usr/share/fio/ 2>/dev/null
fi

# This tool has security/parallel issues -- it hardcodes /tmp/template.fio.
rm "${ED}"/usr/bin/genfio || die

dodoc README REPORTING-BUGS HOWTO
docinto examples
dodoc examples/*
}

0 comments on commit f3b8303

Please sign in to comment.