forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/opencv: version bump 3.4.1
Closes: https://bugs.gentoo.org/642800 Closes: https://bugs.gentoo.org/633900 Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Showing
4 changed files
with
529 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
29 changes: 29 additions & 0 deletions
29
media-libs/opencv/files/opencv-3.4.0-disable-download.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
--- a/CMakeLists.txt 2018-05-13 20:47:11.635871328 +0200 | ||
+++ b/CMakeLists.txt 2018-05-13 20:47:49.289872617 +0200 | ||
@@ -187,6 +187,7 @@ | ||
# ---------------------------------------------------------------------------- | ||
|
||
OCV_OPTION(OPENCV_ENABLE_NONFREE "Enable non-free algorithms" OFF) | ||
+OCV_OPTION(ENABLE_DOWNLOAD "Enable download during configure" ON) | ||
|
||
# 3rd party libs | ||
OCV_OPTION(BUILD_ZLIB "Build zlib from source" WIN32 OR APPLE) | ||
|
||
--- a/cmake/OpenCVDownload.cmake 2018-05-13 21:22:14.966943336 +0200 | ||
+++ b/cmake/OpenCVDownload.cmake 2018-05-13 21:23:15.959945424 +0200 | ||
@@ -32,6 +32,7 @@ | ||
|
||
|
||
function(ocv_download) | ||
+ if(ENABLE_DOWNLOAD) | ||
cmake_parse_arguments(DL "UNPACK;RELATIVE_URL" "FILENAME;HASH;DESTINATION_DIR;ID;STATUS" "URL" ${ARGN}) | ||
|
||
macro(ocv_download_log) | ||
@@ -236,4 +237,7 @@ | ||
if(OCV_DOWNLOAD_HASH_NAME) | ||
set(${OCV_DOWNLOAD_HASH_NAME} "${DL_HASH}" CACHE INTERNAL "") | ||
endif() | ||
+ else() | ||
+ message( "Download was disabled during configure phase by ENABLE_DOWNLOAD=OFF" ) | ||
+ endif() | ||
endfunction() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.