Skip to content

Commit

Permalink
dev-python/virtualenv: Add python3.5 support
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 11, 2015
1 parent d5dc2fa commit f3d0bba
Showing 1 changed file with 53 additions and 0 deletions.
53 changes: 53 additions & 0 deletions dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Virtual Python Environment builder"
HOMEPAGE="
http://www.virtualenv.org/
https://pypi.python.org/pypi/virtualenv
https://github.com/pypa/virtualenv/
"
SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
SLOT="0"
IUSE="doc test"

RDEPEND="
>=dev-python/pip-7.1.2[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)"

DOCS=( docs/index.rst docs/changes.rst )

PATCHES=(
"${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
"${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
)

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
py.test -vvx || die "Tests fail with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit f3d0bba

Please sign in to comment.