forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST genty-1.2.1.tar.gz 21957 SHA256 ba98da9fe33d51afe3bf35ec584851176a3ff9cefc82c4e081bad4a955f0c90f SHA512 fb2aaa8a6197fe9958b4b8544217db948479d7ad3030b573bdd1cd43664e38213674754187ecdd880cd92d9c65bc15fc509956171bce39ee1d11886645e491d6 WHIRLPOOL 693517e5db3f0bb3469ee47697b3e13fa49e2a72d33b4a46c1f84150ca37b3bd9c5ca7b469f649ae717b3de30aa79b35f06cf49af576376ad058dc23f82bdb0a | ||
DIST genty-1.3.0.tar.gz 22751 SHA256 8c480cedf90070160584b6bec1a47a36d4d1c078b9ed24b7afdd21259671fdd3 SHA512 e4ecc19abd6d5175fb30226f1d9ebb453a71aaeb3b02db38adeb73b542e410a30f3b38d0291ca7da192f092be97a38a5a6dafb47f8103c6adb297f7db257af19 WHIRLPOOL b7187d6ff5ec0b92c89b0f963014ff73f55544641a4f3d0afe5f66f834ea763770f18f0c2c372932d9362074d5688ed4b110938d464f000d67deaba915c89484 | ||
DIST genty-1.3.2.tar.gz 20818 SHA256 2e3f5bfe2d3a757c0e2a48ac4716bca42d3b76d9cfc3401ef606635049c35dab SHA512 cfe984dfe5af48ba9f4f959a1d0ab1d331d3c2fdb64c680572e5652b845e5c290097ec3ed2b4e472a563cd6ab79489124f6eb212902a05a2f1ce5ff254a82e13 WHIRLPOOL 0c8d5baa90f50ef3434a3daf827c71afb0532585ee2bfdf6261584818d300513ffb5f91a3114c5b521cc4bcfdc101df7ab37141fbb5420eb6c1895ad63d50449 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 python3_{3,4,5} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Allows you to run a test with multiple data sets" | ||
HOMEPAGE="https://pypi.python.org/pypi/genty https://github.com/box/genty" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
SLOT="0" | ||
LICENSE="Apache-2.0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-python/six[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
" | ||
|
||
# https://github.com/box/genty/issues/42 | ||
RESTRICT=test | ||
|
||
python_test() { | ||
esetup.py test --verbose | ||
} |