Skip to content

Commit

Permalink
app-admin/puppet-agent: bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
prometheanfire committed Feb 28, 2017
1 parent d21df59 commit f43c771
Show file tree
Hide file tree
Showing 2 changed files with 108 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-admin/puppet-agent/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -8,3 +8,5 @@ DIST puppet-agent_1.9.0-1xenial_amd64.deb 15324700 SHA256 acdcdc314b39e404102b8e
DIST puppet-agent_1.9.0-1xenial_i386.deb 16775966 SHA256 c7c5303e411278d19eee798ab7ae68b51edc7256935e6637a58fbb8c035df6ed SHA512 00a29cf00840e8d75e5d858fe03a15338f21e9eead123a1bae5e2a8cca66e06a6bbdc4671a06a986ee8807851997459fc134c6ebb196674e6993fd12af5bbd47 WHIRLPOOL ebac057af1efeb692b6b56fe2a697a79ab45872639add7db903b24f176651e86dfc18651c25acef3b33682dda255562e357e0942b9121b232474dcf1f6617176
DIST puppet-agent_1.9.1-1xenial_amd64.deb 15458462 SHA256 ed7a124842b48a3ec16875dfbdf8942437d1d137768003918ef681838f2bcfc6 SHA512 1eaba0dabc7000b873dc776f74f7f0ea2084cdb0ffb39f4d344798458e20b36f233256d4648676954ecaad7dd1f0762823febe4e948c622dd8e1a599cb23cb7c WHIRLPOOL d1ba1ebc8519eb7329203d9fffd8447c7d3a141cfad798c09dc7011442f7a38da41b9b275778e6c5d5929fae94bd89ee9033f847bb1116d3afe7be90bd4525e0
DIST puppet-agent_1.9.1-1xenial_i386.deb 16870810 SHA256 6739a03ab3ffa69680c84aed79f50e3e0383a50055b1e5f5545a24aec68c3791 SHA512 421b32d2eba33af0bbbbbd41f3615222c1907107023f6cb80bb23a9378f5ba9cc26bac24749c611cc41fc52bca25df92377ba76cfd2d09d1328067138d2a8db3 WHIRLPOOL e9abd1b50856577e7892511b94f9ca64b023f41ff39c6fd106874305380522cf7fd98e0d659eb896d400fd8865510dec7144a7915fa4f3bb069069d74302612f
DIST puppet-agent_1.9.2-1xenial_amd64.deb 15684862 SHA256 97d5cbe6743c7d9dd67289fda74795e4c82b45464560606654c26eea78a72872 SHA512 9a1cb959e174992b1dfc51db5c4c75f0a855469caa41d3e9f8da9c8cbf0b987f222d0cf2105df37a61edc190633f9407f7717379124619dab8650df9ae356f16 WHIRLPOOL e8ddebcab3ae8ba4429c0855792f0b35043cce4d9d10bfc18e0b1a73c1eb43894b54c8743739d8c6b3d2b174684af6b9b620dc7863ea34ccfe9ec475b112247a
DIST puppet-agent_1.9.2-1xenial_i386.deb 16767542 SHA256 5cb35fd22ab2922963192120d3f48d9a92fa7c3b1d25d80c8f0c4c92269cc62a SHA512 7f2e0277ba074b532bcf95e21b4faac7b6699b133202b3abd004337de3a9d3f07e3ed0213c125552878d75d642f7d824ac73314cf83da1ede943e930062aa824 WHIRLPOOL fd200eec4d71331d7b199b1b32c8c8b27d9375f2747c3b871c72bddb2d3a867cb9d46921c052dac72fba4add67aab57b710d4638136d580653d79539f5d69a8e
106 changes: 106 additions & 0 deletions app-admin/puppet-agent/puppet-agent-1.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils systemd unpacker user

DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
HOMEPAGE="https://puppetlabs.com/"
SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
SRC_URI="
amd64? ( ${SRC_BASE}_amd64.deb )
x86? ( ${SRC_BASE}_i386.deb )
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="puppetdb selinux"
RESTRICT="strip"

CDEPEND="!app-admin/augeas
!app-admin/mcollective
!app-admin/puppet
!dev-ruby/hiera
!dev-ruby/facter
!app-emulation/virt-what"

DEPEND="
${CDEPEND}"
RDEPEND="${CDEPEND}
app-portage/eix
sys-apps/dmidecode
sys-libs/glibc
>=sys-libs/readline-6.0
<sys-libs/readline-7.0
selinux? (
sys-libs/libselinux[ruby]
sec-policy/selinux-puppet
)
puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"

S=${WORKDIR}

QA_PREBUILT="
/opt/puppetlabs/puppet
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
/opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
/opt/puppetlabs/puppet/lib/engines/*
/opt/puppetlabs/puppet/lib/virt-what/*
/opt/puppetlabs/puppet/lib/*
/opt/puppetlabs/puppet/bin/*"

pkg_setup() {
enewgroup puppet
enewuser puppet -1 -1 /var/run/puppet puppet
}

src_install() {
# conf.d
doconfd etc/default/puppet
doconfd etc/default/mcollective
doconfd etc/default/pxp-agent
# logrotate.d
insinto /etc/logrotate.d
doins etc/logrotate.d/mcollective
doins etc/logrotate.d/pxp-agent
# puppet itself
insinto /etc/puppetlabs
doins -r etc/puppetlabs/*
# logdir for systemd
dodir var/log/puppetlabs/puppet/
fperms 0750 var/log/puppetlabs/puppet/
# the rest
insinto /opt
dodir opt/puppetlabs/puppet/cache
doins -r opt/*
fperms 0750 /opt/puppetlabs/puppet/cache
# init
newinitd "${FILESDIR}/puppet.initd" puppet
newinitd "${FILESDIR}/mcollective.initd" mcollective
systemd_dounit lib/systemd/system/puppet.service
systemd_dounit lib/systemd/system/mcollective.service
systemd_dounit lib/systemd/system/pxp-agent.service
systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
# symlinks
chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
dosym /opt/puppetlabs/bin/facter /usr/bin/facter
dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
dosym /opt/puppetlabs/bin/mco /usr/bin/mco
dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
}

0 comments on commit f43c771

Please sign in to comment.