Skip to content

Commit

Permalink
dev-cpp/amqp-cpp: add 4.3.16
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
thesamesam authored and SoapGentoo committed Sep 9, 2022
1 parent f117f30 commit f46f90e
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/amqp-cpp/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST AMQP-CPP-4.3.10.tar.gz 156600 BLAKE2B 0453259e8d84b223fc8d36d4747b267a84d7db9daef55d13ff31d4c8cf1e5dd8efb87d9f83f7ff7554aa70c5000d6da45187ce03db09ff4c542bd5409d81ada8 SHA512 ef9a20cd066bbefc243d8d58dbded728e0c88f5c47134f835c50dfa01178b53200970333f0d56330c206f74aa7d7691556c3e4693d5276adb7e3bf4e66bcd057
DIST AMQP-CPP-4.3.16.tar.gz 158954 BLAKE2B 175c5c22a88e20ca5d123fbf808a354a0b3048a0127ba75170b61e8c8822ba8d8b78cb4247cb26cfeebff92c0ca74213d6fb254afbc74e9f92a88751137e8c97 SHA512 bdce6a93f3b88a0ab26dae66e289f98194d0f1a3e2eb03e0c858111275a02ebec042dfe9d757989a1c0cbe1b15652346f86008bf4248e366d1896c4750d9194f
36 changes: 36 additions & 0 deletions dev-cpp/amqp-cpp/amqp-cpp-4.3.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

MY_PN=${PN^^}
MY_P=${MY_PN}-${PV}

DESCRIPTION="AMQP-CPP is a C++ library for communicating with a RabbitMQ message broker"
HOMEPAGE="https://github.com/CopernicaMarketingSoftware/AMQP-CPP"
SRC_URI="https://github.com/CopernicaMarketingSoftware/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"

src_prepare() {
sed \
-e "s:DESTINATION lib:DESTINATION $(get_libdir):g" \
-e "s:DESTINATION cmake:DESTINATION $(get_libdir)/cmake/${PN/-/}:g" \
-i CMakeLists.txt || die

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DAMQP-CPP_BUILD_SHARED=ON
-DAMQP-CPP_LINUX_TCP=ON
)

cmake_src_configure
}

0 comments on commit f46f90e

Please sign in to comment.