Skip to content

Commit

Permalink
dev-dotnet/mono-addins bump to 1.0
Browse files Browse the repository at this point in the history
  • Loading branch information
cnd committed Aug 14, 2015
1 parent 498bf83 commit f4b0a7b
Show file tree
Hide file tree
Showing 3 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-dotnet/mono-addins/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mono-addins-0.6.2.tar.bz2 337614 SHA256 3c24199e1de00860bffcfa0ff0859abe8ee38cacdcbffff0c6854042d8ea2f2c SHA512 6556cf8c82c9f25eba5df88bbec8d9d3dd39ad5b3a904cdadc82d6eccc71b27e07ad2faa2b41eba5b3519fd6dbcc50a398104e396dcae09b152252adb8f3f0f5 WHIRLPOOL b307fb11476bd2e29cdb80260b0c54556ebe5d3a25d4d84751415972085a72680218948fdbf030ba94cf7a5aacf155ce774d399f28771f73ddd41b060269faff
DIST mono-addins-1.0.tar.gz 548940 SHA256 aee8ce94208478c98f04310ff5a7915d6fd143d1431d420911d58d3c6b951647 SHA512 ba2f625b2f9c9f0c367c87670c930b4c8ee874b04721fd1ca636c8ef5c27702256057c9bcebc9a3d1edd7bedd21a700268cbeadeecc795d3004a7b7ada8f5c24 WHIRLPOOL bec45263394880a12839c72283c4b5366af538f819018a0a86aa3f81d304c95da0ce43fe92f8fad8bb6a2a291854c05eb28d913db8ed56d0aa8a6086941b945a
15 changes: 15 additions & 0 deletions dev-dotnet/mono-addins/files/gmcs.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
diff -u origin/configure.ac mono-addins-mono-addins-1.0/configure.ac
--- origin/configure.ac
+++ mono-addins-mono-addins-1.0/configure.ac
@@ -18,7 +18,10 @@

AC_PROG_INSTALL

-AC_PATH_PROG(MCS, gmcs, no)
+MCS=no
+AC_PATH_PROG(MCS, gmcs)
+AC_PATH_PROG(MCS, dmcs)
+AC_PATH_PROG(MCS, mcs)
if test "x$MCS" = "xno"; then
AC_MSG_ERROR([mcs Not found])
fi
52 changes: 52 additions & 0 deletions dev-dotnet/mono-addins/mono-addins-1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils dotnet multilib autotools-utils

DESCRIPTION="A generic framework for creating extensible applications"
HOMEPAGE="http://www.mono-project.com/Mono.Addins"
SRC_URI="http://github.com/mono/${PN}/archive/${P}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+gtk"

RDEPEND=">=dev-lang/mono-3
gtk? ( >=dev-dotnet/gtk-sharp-2.12.21:2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
MAKEOPTS="${MAKEOPTS} -j1" #nowarn

S="${WORKDIR}/${PN}-${P}"

src_prepare() {
epatch "${FILESDIR}/gmcs.patch"

eautoreconf
autotools-utils_src_prepare
## with dev-dotnet/gtk-sharp-2.99.1
## it gives
## checking for GTK_SHARP_20... no
## configure: error: Package requirements (gtk-sharp-2.0) were not met:
##
## No package 'gtk-sharp-2.0' found

sed -i "s;Mono.Cairo;Mono.Cairo, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756;g" Mono.Addins.Gui/Mono.Addins.Gui.csproj || die "sed failed"
}

src_configure() {
econf $(use_enable gtk gui)
}

src_compile() {
default
}

src_install() {
default
dotnet_multilib_comply
}

0 comments on commit f4b0a7b

Please sign in to comment.