Skip to content

Commit

Permalink
media-gfx/displaycal: 3.6.1.1 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.44, Repoman-2.3.10
  • Loading branch information
voyageur committed Aug 8, 2018
1 parent 8f6789f commit f4e1dd6
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/displaycal/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST DisplayCAL-3.5.3.0.tar.gz 10559161 BLAKE2B a3eb968dcd0b5edbcf22a0ec84da55d8660ffa8782135a908db8ea7a6480ce7be9a59528d35a73b7eb57c9c0dd46996407ea3de834a85e6da1c5d006b8aa33b3 SHA512 ddb405c1d8b7bc5aefac80fb79edbb03c2a3b32821c8bbbdd6d095312fff57e8ffe5e53cc5b53c56fa32e6bcbc10cd76598441d750008c38a512ed1f62d7cd9c
DIST DisplayCAL-3.6.0.0.tar.gz 10565171 BLAKE2B 394a925d28f513ededc1bc40b3ce7b5a2687a0c172006fd14b9081188e3ca80c0cd5f634ac84a9917d6aa301e083bffd05db622e292262f6d41db2a86c23a920 SHA512 6d0cff6344bb0dfcff58e88f93e2d0f7a3cf5f8e32b596f9f5e07b0e80ccb9b4ff429aa9fa63b5941f7622e0a7dcd227d0a1066e82d0843454f01d96dea97993
DIST DisplayCAL-3.6.1.1.tar.gz 10433827 BLAKE2B 3e06ea90d820bcc96eb8de8d2fabf9d60997092e1529b3a0a6544bfd42f89380bb2525e27c075a3b8c55721d659b485188e8e7f2e872622ed9e6b6ebc87ac662 SHA512 03835117f53fb8c9d7cedfe67719b70878c3b62c20894a999c971d1d820dc7ec386ad68b8d4cf19496005abf2235e789526e6632b11d82f971f944b5f4dfdac6
63 changes: 63 additions & 0 deletions media-gfx/displaycal/displaycal-3.6.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 gnome2-utils xdg

MY_PN="DisplayCAL"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
HOMEPAGE="https://displaycal.net/"
SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
>=media-gfx/argyllcms-1.1.0
dev-python/wxpython:3.0
>=x11-libs/libX11-1.3.3
>=x11-apps/xrandr-1.3.2
>=x11-libs/libXxf86vm-1.1.0
>=x11-libs/libXinerama-1.1
"
RDEPEND="${DEPEND}
>=dev-python/numpy-1.2.1
"

# Just in case someone renames the ebuild
S="${WORKDIR}/${MY_P}"

src_prepare() {
# Do not generate udev/hotplug files
sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
-i DisplayCAL/setup.py || die
# Prohibit setup from running xdg-* programs, resulting to sandbox violation
sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
-e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
-i DisplayCAL/postinstall.py || die

# Remove deprecated Encoding key from .desktop file
sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die

# Remove x-world Media Type
sed -e 's/x\-world\/x\-vrml\;//g' \
-i misc/displaycal-vrml-to-x3d-converter.desktop || die

distutils-r1_src_prepare
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_icon_cache_update
}

0 comments on commit f4e1dd6

Please sign in to comment.