Skip to content

Commit

Permalink
app-text/libmwaw: Add upstream buildfix
Browse files Browse the repository at this point in the history
Reported-by: Coacher <[email protected]>
Thanks-to: Shannon <[email protected]>
Closes: https://bugs.gentoo.org/637692
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
a17r committed Nov 18, 2017
1 parent 592ad0a commit f4f32f6
Show file tree
Hide file tree
Showing 2 changed files with 21 additions and 0 deletions.
19 changes: 19 additions & 0 deletions app-text/libmwaw/files/libmwaw-0.3.13-buildfix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
commit 4bc8ec0481f89b989b0c34236c9d5d9b8038d4a9
Author: David Tardon <[email protected]>
Date: Wed Nov 15 13:15:44 2017 +0100

fix call of explicit ctor

diff --git a/src/lib/libmwaw_internal.hxx b/src/lib/libmwaw_internal.hxx
index 2875a0fb..b844a9d5 100644
--- a/src/lib/libmwaw_internal.hxx
+++ b/src/lib/libmwaw_internal.hxx
@@ -1027,7 +1027,7 @@ public:
}
//! generic constructor
template <class U> explicit MWAWBox2(MWAWBox2<U> const &p)
- : m_data(p.min(), p.max())
+ : m_data(MWAWVec2<T>(p.min()), MWAWVec2<T>(p.max()))
{
}

2 changes: 2 additions & 0 deletions app-text/libmwaw/libmwaw-0.3.13.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -28,6 +28,8 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
"

PATCHES=( "${FILESDIR}/${P}-buildfix.patch" )

src_prepare() {
default
[[ ${PV} == 9999 ]] && eautoreconf
Expand Down

0 comments on commit f4f32f6

Please sign in to comment.