Skip to content

Commit

Permalink
dev-go/golangci-lint: add 1.59.1
Browse files Browse the repository at this point in the history
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
williamh committed Aug 7, 2024
1 parent e15f755 commit f518547
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-go/golangci-lint/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,5 @@ DIST golangci-lint-1.55.2-deps.tar.xz 43815104 BLAKE2B a352c9cad3e5e2f5544320fc0
DIST golangci-lint-1.55.2.tar.gz 1687534 BLAKE2B 14bfbeabd5e08c871e368b8dd94a5e2cc4f1673e5b221d1d5d44b0fed076ea68a80b563d562803fcb384c655bb1689f891e255990059e9720804373d1d51d43c SHA512 286749a6aaa89ae7400894b04fa64490543cbc4703c0d5a9252cfe01fba331e1323828b57d5051bf13dc041b5266a979ed31facba610d0814fce0462f5571718
DIST golangci-lint-1.56.2-deps.tar.xz 140638164 BLAKE2B 669e2ef488f1bf00c9d4d8f5a0cca708f223bedc894c9ca4affa6a03e6c8c9b77ad1ff37f5c1eb1054203aaf86285410cbf805f9eb529f8788b1d390d3c58c81 SHA512 50c0e83c353d83dce468e2fefce6ec351ac486b9e94e8999232769d201636fde0c9aa73f1e1306ee33be3720b554bc04866e3d86eb836517fbcfbb36a1e2b91a
DIST golangci-lint-1.56.2.tar.gz 1695476 BLAKE2B 8e27301bab34cd0adf80943effac342653901adb148a7b232bde6f6fad8fdcfbece10cdd7f6b91a6eeecb2106bc765156392ec62befdb5309b947fe9098b64f8 SHA512 ab768d58f0888cbda2728c90ac9063f4f15b4fd0e13eefc23a0af4994801860ce9ed9585903678f0e917381f56d8db3941af59c32b287b5e0e58177bff29f4d1
DIST golangci-lint-1.59.1-deps.tar.xz 22945248 BLAKE2B 7fa2ebe069bdb160ac699fc9dfaed43bd64be0c95e5534e4f1f252e46762f462581ce207e4a10b14892f14e98fb86e3c92e205b03f2cf30ee4608443a26c3981 SHA512 a0657ae96e9e4ef100768f9d6e035d0eae3c70c331be912a76f49250eb5c1da681abfc8e397e594a00a73d2db7a47d2ca822b86a1b5afc650d8dd15c1c4796b6
DIST golangci-lint-1.59.1.tar.gz 1713897 BLAKE2B be46b4f1352e08e83abe1bed2f7955c231a8abd493ce57e659fb8c582336149785383b01a0a1db7a669f2075a14ecd741e5e4471d59c5ff06b1cefdedb9e7bc3 SHA512 630a14dd1c3889a0cdb4d085a122a038ed677bc685cc34827aed5f9702e96c82d73695fe63353bc39f261dd29e0b10eb9e17bc279cc4b9aab5efd008f0f1db73
29 changes: 29 additions & 0 deletions dev-go/golangci-lint/golangci-lint-1.59.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module
DESCRIPTION="Fast linters runner for Go"
HOMEPAGE="https://github.com/golangci/golangci-lint"
SRC_URI="https://github.com/golangci/golangci-lint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"

RESTRICT="test"

src_compile() {
emake build
}

src_test() {
emake test
}

src_install() {
dobin golangci-lint
einstalldocs
dodoc CHANGELOG.md
}

0 comments on commit f518547

Please sign in to comment.