Skip to content

Commit

Permalink
dev-ml/flow_parser: bump to 0.50.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
aballier committed Jul 15, 2017
1 parent a623232 commit f531f84
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/flow_parser/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST flow-0.48.0.tar.gz 2612834 SHA256 8772896075dc4028e62720fe18a6608f278f471931b2a8fff280d0efc0fd4f29 SHA512 cad7c38cdb629113955c93480eb7e12a33e5048536d4ae43416998c75913bdb63df5047774e7ac6225ba8f9d56aa232949fcdad7dae26316f5724b4af5de762d WHIRLPOOL 817482d0d17758a4eb61412a4b27e24f11e19d2bb431c2445120a4a62bb8d8b29b31f686632d5453de8073b9929acab2b7fc34286391c002b5390a275361c82f
DIST flow-0.49.1.tar.gz 2630020 SHA256 d72a3470e7e0879d37f242aa0ec561ed0e60ff9fba676156392e46fd5e27a180 SHA512 416773b9c2c9d4f50d4a86da5b00038b732bad8a4434c4aeed1a5e2d2cfe24ae190b1ba0912287ce6d4435a45502daa73ff7fc3f9cb0676b204d3ca2f98e66ba WHIRLPOOL b5a55b34507c9656e93541ada65d9d998d36b4d0ac5ae48501c95c97ffad6b1e2780c78764bdfa156ed9130a43f9e76572dba0b0395b6ff95df90b0ed0a0ae21
DIST flow-0.50.0.tar.gz 2664071 SHA256 859b6f5e1fce4d5813591fbc08e60605630d0b15e1825f877876ecd1476b8fdd SHA512 757adc6c07461ca71a132715a3f19e3dc36a08a165519793b94c667d116563eca9937593700db3efdd8d5cbb5709d5778a49345052de2392697f7bb2221e43e5 WHIRLPOOL ce930a138e5039e58952002f9c961ce366be47d5491bc572f058735f57cff69d2b8367f83f3c4a3a4d06f8fe00f7ad1cd95eb3b9dac8ad3808716411377c06d9
39 changes: 39 additions & 0 deletions dev-ml/flow_parser/flow_parser-0.50.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit findlib

DESCRIPTION="JavaScript parser written in OCaml"
HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""

DEPEND="
dev-lang/ocaml:=
dev-ml/sedlex:=
"
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
dev-ml/ocamlbuild"

S="${WORKDIR}/flow-${PV}/src/parser"

src_compile() {
emake build-parser
}

src_test() {
emake test-ocaml
}

src_install() {
findlib_src_preinst
emake ocamlfind-install
dodoc README.md
}

0 comments on commit f531f84

Please sign in to comment.