Skip to content

Commit

Permalink
sci-electronics/iverilog: add 12.0
Browse files Browse the repository at this point in the history
Signed-off-by: Huang Rui <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
vowstar authored and juippis committed Apr 10, 2023
1 parent ad14f8c commit f538023
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-electronics/iverilog/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST iverilog-10.3.tar.gz 1600835 BLAKE2B 107c57c61fb27c18f4020f7853bf6ca83d1a86fdc73c57ea207828baf6b7a26d42e43ce7b33580f050a4c0b8f63bca6accecf678323a3bbbee1eb9c1d8fa2caa SHA512 67076e19a208576c21a0462ff7d15d00a9d47740c47518a5523bd928b3118360d85eb84c317963717d15e5246ece3727259f6ff3baf59e195340530cc9086a1d
DIST iverilog-11.0.tar.gz 1682457 BLAKE2B ba90574e1453a095143e76e5dc79bb2357a721fc62c24f0fb23d220458819cb3b8ea8494410ce956e68831b682b61f27f64e94e9c166a69e5f6d5d30a8269a11 SHA512 5d6a65e1c3b6b62e99af708cd5a259cc69c6b789dd6eff69e225903d9b8c115d9e5d6f7635b30c6558197cd0ee6fd8196a163fbd98956e24c211d97328b85056
DIST iverilog-12.0.tar.gz 2995096 BLAKE2B 7e1d4d8302168da3d38aac113daaaa62b80e59d7485be142443cd57ef346e788d9b58564af491a0ad58f64c06e475696238205f3e673f10da3c2cd417020fbed SHA512 a8e112f760903335ef2fbf00529e5fe282b83c1f583c4316373b9410d7fad2a53d5c4adb82dd62491c14a620cb5b1fab117cb0cde638c86b65fe5b7b0dd07152
65 changes: 65 additions & 0 deletions sci-electronics/iverilog/iverilog-12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

GITHUB_PV=$(ver_rs 1- '_')

DESCRIPTION="A Verilog simulation and synthesis tool"
HOMEPAGE="
http://iverilog.icarus.com
https://github.com/steveicarus/iverilog
"

if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/steveicarus/${PN}.git"
else
SRC_URI="https://github.com/steveicarus/${PN}/archive/v${GITHUB_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}/${PN}-${GITHUB_PV}"
fi

LICENSE="LGPL-2.1"
SLOT="0"

DEPEND="
sys-libs/readline:=
sys-libs/zlib
"
RDEPEND="${DEPEND}"
BDEPEND="
dev-util/gperf
sys-devel/bison
sys-devel/flex
"

src_prepare() {
default

# From upstreams autoconf.sh, to make it utilize the autotools eclass
# Here translate the autoconf.sh, equivalent to the following code
# > sh autoconf.sh

# Autoconf in root ...
eautoconf

# Precompiling lexor_keyword.gperf
gperf -o -i 7 -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf \
> lexor_keyword.cc || die
# Precompiling vhdlpp/lexor_keyword.gperf
cd vhdlpp || die
gperf -o -i 7 --ignore-case -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf \
> lexor_keyword.cc || die
}

src_install() {
local DOCS=( *.txt )

default

dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
}

0 comments on commit f538023

Please sign in to comment.