Skip to content

Commit

Permalink
app-text/htmldoc: Bump to version 1.8.29
Browse files Browse the repository at this point in the history
This bump includes 2 patches:
- One to patch out the complete lack of DESTDIR support upstream
- The other is to patch an annoying defect where failures in child
 Make targets result in "make" returning true, and the build finishing
 and installing in a broken state.

Upstream have dropped SSL Support.

This will hopefully resolve several bugs:
- https://bugs.gentoo.org/572262 - Toralf
- https://bugs.gentoo.org/549960 - Toralf
- https://bugs.gentoo.org/527624 - Diego

Thanks to Toralf Förster and Diego Elio Pettenò for reporting the bugs.

Package-Manager: portage-2.2.28
RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
  • Loading branch information
kentfredric authored and akhuettel committed Apr 15, 2016
1 parent 83b4d16 commit f58c0f6
Show file tree
Hide file tree
Showing 4 changed files with 179 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/htmldoc/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST htmldoc-1.8.27-source.tar.bz2 3960271 SHA256 89ffd223734268375dc959c200622dc5f167576c5cad9d7ce4bd7567faeb9613 SHA512 f0b2b6fec4925e549e74d6721f15b5de00c8c4889b0c67689945c408ed88074acb1330cae155655a1986adc0ca549cea32e242aa1ecac8e6338a1739f7c85438 WHIRLPOOL 0716ef8e70d11208668685b3b2cc742111940c91264a97531e705351721f3f14260c05479f35f73c2961238e163e0f5407c5bb2769984ccbcb5063736ebd4b39
DIST htmldoc-1.8.29-source.tar.bz2 4089227 SHA256 e8c96ad740d19169eab8305c8e2ee1c795c4afa59ba99d18786ad191a2853f31 SHA512 06c4367b84005624564dfb33d2cc632cbfc711268ffce9efe00c17760da17637949fc7415fd29fcd63edc26ba96ff18cf57d1e9d36e7205b92ac2095cf4acfc8 WHIRLPOOL 3efe016ce4e071d164e3ca44fe3c8cba9ba830eb0847215116fbccab45b7ae913bfe94c723d4c8ba952c48ce31c68e5c4a71bd7048030a03c8fb3dffe42ea6d3
30 changes: 30 additions & 0 deletions app-text/htmldoc/files/htmldoc-break.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
diff -Naur htmldoc-1.8.29b/Makefile.in htmldoc-1.8.29c/Makefile.in
--- htmldoc-1.8.29b/Makefile.in 2016-04-13 17:02:29.706811414 +0000
+++ htmldoc-1.8.29c/Makefile.in 2016-04-13 17:03:37.713630261 +0000
@@ -39,7 +39,7 @@
all: Makedefs Makefile config.h htmldoc.list
for dir in $(DIRS); do\
echo Making all in $$dir...;\
- (cd $$dir; $(MAKE) -$(MAKEFLAGS)) || break;\
+ (cd $$dir; $(MAKE) -$(MAKEFLAGS)) || exit 1;\
done


@@ -50,7 +50,7 @@
clean:
for dir in $(DIRS); do\
echo Cleaning in $$dir...;\
- (cd $$dir; $(MAKE) -$(MAKEFLAGS) clean) || break;\
+ (cd $$dir; $(MAKE) -$(MAKEFLAGS) clean) || exit 1;\
done
$(RM) *.bak
$(RM) *.bck
@@ -77,7 +77,7 @@
$(MAKE) all
for dir in $(INSTALLDIRS); do\
echo Installing in $$dir...;\
- (cd $$dir; $(MAKE) -$(MAKEFLAGS) install) || break;\
+ (cd $$dir; $(MAKE) -$(MAKEFLAGS) install) || exit 1;\
done


91 changes: 91 additions & 0 deletions app-text/htmldoc/files/htmldoc-destdir.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
diff -Naur htmldoc-1.8.29/data/Makefile htmldoc-1.8.29b/data/Makefile
--- htmldoc-1.8.29/data/Makefile 2011-12-23 06:23:11.000000000 +0000
+++ htmldoc-1.8.29b/data/Makefile 2016-04-13 16:59:35.074270457 +0000
@@ -41,11 +41,11 @@
#

install:
- if [ ! -d $(datadir)/htmldoc/data ]; then\
- $(MKDIR) $(datadir)/htmldoc/data;\
+ if [ ! -d $(DESTDIR)$(datadir)/htmldoc/data ]; then\
+ $(MKDIR) $(DESTDIR)$(datadir)/htmldoc/data;\
fi
- $(CP) $(FILES) $(datadir)/htmldoc/data
- $(CHMOD) ugo+r $(datadir)/htmldoc/data/*
+ $(CP) $(FILES) $(DESTDIR)$(datadir)/htmldoc/data
+ $(CHMOD) ugo+r $(DESTDIR)$(datadir)/htmldoc/data/*


#
diff -Naur htmldoc-1.8.29/doc/Makefile htmldoc-1.8.29b/doc/Makefile
--- htmldoc-1.8.29/doc/Makefile 2016-01-02 22:58:41.000000000 +0000
+++ htmldoc-1.8.29b/doc/Makefile 2016-04-13 16:57:46.628550948 +0000
@@ -45,16 +45,16 @@
#

install: $(DOCUMENTS)
- if test ! -d $(datadir)/doc/htmldoc; then\
- $(MKDIR) $(datadir)/doc/htmldoc;\
+ if test ! -d $(DESTDIR)$(datadir)/doc/htmldoc; then\
+ $(MKDIR) $(DESTDIR)$(datadir)/doc/htmldoc;\
fi
- $(CP) $(DOCFILES) $(datadir)/doc/htmldoc
- $(CHMOD) ugo+r $(datadir)/doc/htmldoc/*
- if test ! -d $(mandir)/man1; then\
- $(MKDIR) $(mandir)/man1;\
+ $(CP) $(DOCFILES) $(DESTDIR)$(datadir)/doc/htmldoc
+ $(CHMOD) ugo+r $(DESTDIR)$(datadir)/doc/htmldoc/*
+ if test ! -d $(DESTDIR)$(mandir)/man1; then\
+ $(MKDIR) $(DESTDIR)$(mandir)/man1;\
fi
- $(CP) htmldoc.man $(mandir)/man1/htmldoc.1
- $(CHMOD) ugo+r $(mandir)/man1/htmldoc.1
+ $(CP) htmldoc.man $(DESTDIR)$(mandir)/man1/htmldoc.1
+ $(CHMOD) ugo+r $(DESTDIR)$(mandir)/man1/htmldoc.1


#
diff -Naur htmldoc-1.8.29/fonts/Makefile htmldoc-1.8.29b/fonts/Makefile
--- htmldoc-1.8.29/fonts/Makefile 2011-12-23 06:23:11.000000000 +0000
+++ htmldoc-1.8.29b/fonts/Makefile 2016-04-13 16:56:35.317733427 +0000
@@ -62,15 +62,15 @@
#

install:
- echo "Installing font files in $(datadir)/htmldoc/fonts..."
- if [ ! -d $(datadir)/htmldoc/fonts ]; then\
- $(MKDIR) $(datadir)/htmldoc/fonts;\
+ echo "Installing font files in $(DESTDIR)$(datadir)/htmldoc/fonts..."
+ if [ ! -d $(DESTDIR)$(datadir)/htmldoc/fonts ]; then\
+ $(MKDIR) $(DESTDIR)$(datadir)/htmldoc/fonts;\
fi
for font in $(FONTS); do \
- $(CP) $$font.afm $(datadir)/htmldoc/fonts; \
- $(CP) $$font.pfa $(datadir)/htmldoc/fonts; \
+ $(CP) $$font.afm $(DESTDIR)$(datadir)/htmldoc/fonts; \
+ $(CP) $$font.pfa $(DESTDIR)$(datadir)/htmldoc/fonts; \
done
- $(CHMOD) ugo+r $(datadir)/htmldoc/fonts/*
+ $(CHMOD) ugo+r $(DESTDIR)$(datadir)/htmldoc/fonts/*


#
diff -Naur htmldoc-1.8.29/htmldoc/Makefile htmldoc-1.8.29b/htmldoc/Makefile
--- htmldoc-1.8.29/htmldoc/Makefile 2016-01-02 21:46:20.000000000 +0000
+++ htmldoc-1.8.29b/htmldoc/Makefile 2016-04-13 16:56:35.318733424 +0000
@@ -38,11 +38,11 @@
#

install: all
- if [ ! -d $(bindir) ]; then\
- $(MKDIR) $(bindir);\
+ if [ ! -d $(DESTDIR)$(bindir) ]; then\
+ $(MKDIR) $(DESTDIR)$(bindir);\
fi
- cp htmldoc$(EXEEXT) $(bindir)
- chmod ugo+rx $(bindir)/htmldoc$(EXEEXT)
+ cp htmldoc$(EXEEXT) $(DESTDIR)$(bindir)
+ chmod ugo+rx $(DESTDIR)$(bindir)/htmldoc$(EXEEXT)


#
57 changes: 57 additions & 0 deletions app-text/htmldoc/htmldoc-1.8.29.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="Convert HTML pages into a PDF document"
SRC_URI="http://www.msweet.org/files/project1/${P}-source.tar.bz2"
HOMEPAGE="http://www.msweet.org/projects.php?Z1"

IUSE="fltk"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"

DEPEND=">=media-libs/libpng-1.4:0=
virtual/jpeg:0
fltk? ( x11-libs/fltk:1 )
"
RDEPEND="${DEPEND}"

src_prepare() {
# make sure not to use the libs htmldoc ships with
mkdir foo ; mv jpeg foo/ ; mv png foo/ ; mv zlib foo/

sed -i "s:^#define DOCUMENTATION \"\$prefix/share/doc/htmldoc\":#define DOCUMENTATION \"\$prefix/share/doc/${PF}/html\":" \
configure || die

eapply "${FILESDIR}/${PN}-destdir.patch" \
"${FILESDIR}/${PN}-break.patch"

default
}

src_configure() {
local myconf="$(use_with fltk gui)"

econf ${myconf}
# Add missing -lfltk_images to LIBS
if use fltk; then
sed -i 's:-lfltk :-lfltk -lfltk_images :g' Makedefs || die
fi
}

src_compile() {
emake
}

src_install() {
emake DESTDIR="${D}" install

# Minor cleanups
mv "${D}/usr/share/doc/htmldoc" "${D}/usr/share/doc/${PF}"
dodir /usr/share/doc/${PF}/html
mv "${D}"/usr/share/doc/${PF}/*.html "${D}/usr/share/doc/${PF}/html"
}

0 comments on commit f58c0f6

Please sign in to comment.