forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
30 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST ipdb-0.8.1.zip 20522 SHA256 1763d1564113f5eb89df77879a8d3213273c4d7ff93dcb37a3070cdf0c34fd7c SHA512 515f282cb82ea989670a77956c02ac6433c125beba94c67b1eb90058c2427aac2345d02bb64b71a9593abbf7539d5ab0c20675bd24dde294b1e00544748da65c WHIRLPOOL 3e91eced09d5da6a0fc5442a6df97947fdd018bf73cd52ce0f4800e12f0a1c92f3168c3a171395e601669238b9cbebae0507cce60ca2db02a7f2610ffd73afc2 | ||
DIST ipdb-0.8.2.tar.gz 13623 SHA256 9ac7193658c787321c79b366a3f415f968a215b4d7647508311415944762b727 SHA512 7b1f53787adffb3342f08fc55934e2e0188a990da1ec5661caae9879bb10d1678fd5f6e75268eb9125d5db648416328ae6937af8fbe097475a21751eb94f6624 WHIRLPOOL dee992900579ac68c14dcd171442541d8dcc24cccdc28b321e82d7b3b8ce3617fac7837a15db82f346717b3ac50aed166cd87985d1bac2be28c09629e31a6764 | ||
DIST ipdb-0.8.zip 20204 SHA256 0d4a33f38e667a0c80ec1a5a0e468fe58e5cdc61cb8f4077b1024b85fe7b7117 SHA512 8d0c510a80efeb3ca9a87e4a573bbd0d75629789dec33ebd135f8c9285a276af2cfe5b6628d0bb121a3dbf9e6f248a19a341d9b475b7bfaa15bb9bdca0584dde WHIRLPOOL 376a2c872ae45e943fb99e8cc201f8d8e2a3ebcdc84dde5d1857269170ab6379d8eb2106567484d4eb2454a5c38e6c355d7a136cf74fab40b907fcabef2d6b8f | ||
DIST ipdb-0.9.0.tar.gz 7798 SHA256 efdf16f3ac7b9f14f6ad6d50e95034e03124a65d30d8b24ed20f0e34aa61e5ef SHA512 46f9e8ebe2443e18f9a274ac3601e16bd8e893095fe26039e65c18bf7c1e23710288d1ee59c32409f220f11c047f2dc2031bd8171dca9ac1b7146778954aa6f6 WHIRLPOOL c17d39db52f1cda6682d127f8d1cdc15be36586768e6eaba499d5fa74d410d585de712784537d97d54763f32168f56dd85e7939b977fe0495b74479ee0255d72 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 python3_{3,4,5} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="IPython-enabled pdb" | ||
HOMEPAGE="https://pypi.python.org/pypi/ipdb" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]" | ||
DEPEND="${RDEPEND} | ||
app-arch/unzip | ||
dev-python/setuptools[${PYTHON_USEDEP}]" | ||
|
||
DOCS=( HISTORY.txt ) | ||
|
||
python_test() { | ||
esetup.py test | ||
} |