Skip to content

Commit

Permalink
app-editors/neovim: bump to 0.4.4
Browse files Browse the repository at this point in the history
* Bump to 0.4.4
* Pave the way for tests, but we can't yet because
  dev-lua/busted lacks luajit support (needed for tests).
* Make LTO optional.

Bug: https://bugs.gentoo.org/584694
Closes: https://bugs.gentoo.org/744184
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Sep 30, 2020
1 parent ed273ce commit f60946b
Show file tree
Hide file tree
Showing 5 changed files with 116 additions and 11 deletions.
1 change: 1 addition & 0 deletions app-editors/neovim/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST neovim-0.4.3.tar.gz 9556199 BLAKE2B 831f4d4950f4fa2cd9c7393824bbb5eb571ae5759d13af9f320e0fa351fa155413a5be580f010f2c7ab43ca7bc10c569ccf6e3ba29efc7f5a035576b030b216d SHA512 e13853fa296eda8618f389c71b6cbbd6f01d561615e80cc92959131dd10e395b1c6732a7d9ef6dbb9fe3ea9da4c11485b464547e2d46b22e59b8a20214e861f5
DIST neovim-0.4.4.tar.gz 9558246 BLAKE2B b1d44898bb1e1ab40a7e1d7fb4448076c991ebe1a0956674548de82fe7a931d9eaffbf35ba03cf9c88466dcd628a55f1d7bf9e7a13f3dad74424d6d653ded60c SHA512 ca5c2fe1784ac7b0d2117948ba2e9ae5d94e36d22ff9e0967047e1e03e605537672d85543897af335103215ad462c86962f25267d352a77d61bc3d1cafb3c183
1 change: 1 addition & 0 deletions app-editors/neovim/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
<name>Gentoo Vim Project</name>
</maintainer>
<use>
<flag name="lto">Build with Link Time Optimization (LTO)</flag>
<flag name="nvimpager">Install nvimpager symlink to less.sh macro</flag>
<flag name="tui">Build the neovim unix tui</flag>
</use>
Expand Down
4 changes: 0 additions & 4 deletions app-editors/neovim/neovim-0.4.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,6 @@ BDEPEND="
virtual/libintl
virtual/pkgconfig
"

DEPEND="
dev-libs/libuv:0=
>=dev-libs/libvterm-0.1.2
Expand All @@ -45,16 +44,13 @@ DEPEND="
>=dev-libs/unibilium-2.0.0:0=
)
"

RDEPEND="
${DEPEND}
app-eselect/eselect-vi
"

CMAKE_BUILD_TYPE=Release

PATCHES=( "${FILESDIR}"/${P}-gcc-10-fix.patch )

src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
Expand Down
99 changes: 99 additions & 0 deletions app-editors/neovim/neovim-0.4.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake optfeature xdg

DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+lto +luajit +nvimpager +tui"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
#REQUIRED_USE="test? ( luajit )"
#RESTRICT="!test? ( test )"

BDEPEND="
dev-util/gperf
virtual/libiconv
virtual/libintl
virtual/pkgconfig
"
# Once dev-lua/busted has luajit support, we can add tests.
# bug #584694
DEPEND="
dev-libs/libuv:0=
>=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
dev-lua/lpeg[luajit=]
dev-lua/luv[luajit=]
dev-lua/mpack[luajit=]
net-libs/libnsl
luajit? ( dev-lang/luajit:2 )
!luajit? (
dev-lang/lua:=
dev-lua/LuaBitOp
)
tui? (
dev-libs/libtermkey
>=dev-libs/unibilium-2.0.0:0=
)
"
RDEPEND="
${DEPEND}
app-eselect/eselect-vi
"

src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
-i src/nvim/globals.h || die

cmake_src_prepare
}

src_configure() {
# Upstream default to LTO on non-debug builds
# Let's expose it as a USE flag because upstream
# have preferences for how we should use LTO
# if we want it on (not just -flto)
# ... but allow turning it off.
local mycmakeargs=(
-DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex luajit no yes)
)
cmake_src_configure
}

src_install() {
cmake_src_install

# install a default configuration file
insinto /etc/vim
doins "${FILESDIR}"/sysinit.vim

# conditionally install a symlink for nvimpager
if use nvimpager; then
dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
fi
}

pkg_postinst() {
xdg_pkg_postinst
optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
optfeature "Python plugin support" dev-python/pynvim
optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
optfeature "remote/nvr support" dev-python/neovim-remote
}
22 changes: 15 additions & 7 deletions app-editors/neovim/neovim-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -13,24 +13,29 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+luajit +nvimpager +tui"
IUSE="+lto +luajit +nvimpager +tui"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
#REQUIRED_USE="test? ( luajit )"
#RESTRICT="!test? ( test )"

BDEPEND="
dev-util/gperf
virtual/libiconv
virtual/libintl
virtual/pkgconfig
"

# Once dev-lua/busted has luajit support, we can add tests.
# bug #584694
DEPEND="
dev-libs/libutf8proc:=
dev-libs/libuv:0=
>=dev-libs/libvterm-0.1
>=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
dev-lua/lpeg[luajit=]
dev-lua/luv[luajit=]
Expand All @@ -46,14 +51,11 @@ DEPEND="
>=dev-libs/unibilium-2.0.0:0=
)
"

RDEPEND="
${DEPEND}
app-eselect/eselect-vi
"

CMAKE_BUILD_TYPE=Release

src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
Expand All @@ -63,7 +65,13 @@ src_prepare() {
}

src_configure() {
# Upstream default to LTO on non-debug builds
# Let's expose it as a USE flag because upstream
# have preferences for how we should use LTO
# if we want it on (not just -flto)
# ... but allow turning it off.
local mycmakeargs=(
-DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex luajit no yes)
)
Expand Down

0 comments on commit f60946b

Please sign in to comment.