forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-plugins/kodi-game-libretro-twentyfortyeight: 1.0.0.107 version …
…bump Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Craig Andrews <[email protected]>
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kodi-game-libretro-twentyfortyeight-1.0.0.106.tar.gz 94621 BLAKE2B 584e66eedb9956e75997fc8792652e0c5982150657169687976f0a52ecd07da1d50d2c43aed9379379a8cf1c668a1e9fda2c4c375910bbe02101d67f7813ff65 SHA512 2a30089b617bbbe62af7b17821e69d8c7bc8a393abbfdff5980b62753763595a93e6c326ee4ff17f4d48801399b325634d72c13ca22a30c4c490dfcc7c21952a | ||
DIST kodi-game-libretro-twentyfortyeight-1.0.0.107.tar.gz 94629 BLAKE2B e821c3ec34d46555048d8b76e8f6ddeb8afd6bcaaace32e057e8238eda9bc16ee3a24f2dab5c1d9e2bb94d5823c9c9eb51d912b5f1ebd061404566197a8bb037 SHA512 5a5a7ad82f42673cdc53595a06e484a2bc06ba93ba1a41e26a8d817dc70d342c3a5d74efead426504a5953b92dd5cb95048bf14bda4a4f96a881ffb3d1d2aa23 |
39 changes: 39 additions & 0 deletions
39
.../kodi-game-libretro-twentyfortyeight/kodi-game-libretro-twentyfortyeight-1.0.0.107.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils kodi-addon | ||
|
||
DESCRIPTION="2048 for Kodi" | ||
HOMEPAGE="https://github.com/kodi-game/game.libretro.2048" | ||
SRC_URI="" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
SRC_URI="" | ||
EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.2048.git" | ||
inherit git-r3 | ||
else | ||
KEYWORDS="~amd64 ~x86" | ||
CODENAME="Leia" | ||
SRC_URI="https://github.com/kodi-game/game.libretro.2048/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/game.libretro.2048-${PV}-${CODENAME}" | ||
fi | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
=media-tv/kodi-18* | ||
games-emulation/libretro-twentyfortyeight | ||
" | ||
RDEPEND=" | ||
media-plugins/kodi-game-libretro | ||
${DEPEND} | ||
" | ||
|
||
src_prepare() { | ||
echo 'find_library(2048_LIB NAMES 2048_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-2048.cmake" || die | ||
default | ||
} |