Skip to content

Commit

Permalink
dev-ruby/autoprefixer-rails: install javascript file
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
graaff committed Jun 22, 2017
1 parent 6a476fc commit f653829
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md"

RUBY_FAKEGEM_EXTRAINSTALL="vendor"

inherit ruby-fakegem

DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
HOMEPAGE="https://github.com/ai/autoprefixer-rails"
LICENSE="MIT"

KEYWORDS="~amd64"
SLOT="7"
IUSE=""

ruby_add_rdepend "dev-ruby/execjs:*"

ruby_add_bdepend "dev-ruby/rails
dev-ruby/rake
dev-ruby/rspec-rails"

all_ruby_prepare() {
sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
rm spec/rails_spec.rb spec/compass_spec.rb || die
}

0 comments on commit f653829

Please sign in to comment.