Skip to content

Commit

Permalink
dev-embedded/parapin: Versions 1.5.0 1.5.1_beta1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Oct 10, 2018
1 parent 3dacec1 commit f676921
Show file tree
Hide file tree
Showing 3 changed files with 80 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-embedded/parapin/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,3 @@
DIST parapin-1.0.0.tar.gz 240771 BLAKE2B 3c211d43028f1ee4b09568eae2408b96c9b3c1ecce5b81f3fd520ea3f480bb06044e99e04e7776b8a2b6cf7f99e57f2dcf186aea2ba9afbe4c31b9e0be3bc894 SHA512 43e4066b649bec8519c98052451ab1beb720c9c8086bbd045bb013e3c12c7e83bf0411ac4b8e7006c3acbc6d1487b918d26df65b246469e6c7e008a0e26874d9
DIST parapin-1.5.0.tgz 249552 BLAKE2B 2a6621ec21542c35dbcae48f1bb93cd36621878b3bdfcb75f3b22aaa861e730a0f9f80f0d83eb4335d7d3b4c6c471e83003da5daea6dddc87b6e3c86ef2c7229 SHA512 732a2e4145f9dc2b765ecd1fd52d56409e69f4e3dc885f10d37661ab551604b986c95466e7d45265a268f7e759f6aa65537d1a8efcdd57d2d8b0ddfd3484728d
DIST parapin-1.5.1-beta1.tgz 279115 BLAKE2B cce949828fec7654917da54be30ac6ed07baad615180adebbd12caba0c994e62ae95cc10a00c3653d23fe75afbe0721d6da901829a99a89ab355ea059c99d0f5 SHA512 3bc1a0a9fef5fd5f8efd84220e7e257a100d618d168332fe09c1331c38fc48e339bfda3f216713f454f43487fd7227036d8f1025ccc851806ae69326bfae97e0
38 changes: 38 additions & 0 deletions dev-embedded/parapin/parapin-1.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit toolchain-funcs

DESCRIPTION="A parallel port pin programming library"
HOMEPAGE="http://parapin.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"

LICENSE="LGPL-2.1"
IUSE="doc"
KEYWORDS="~amd64 ~x86"
SLOT="0"

DEPEND="doc? ( dev-tex/latex2html )"

src_compile() {
# Note 2.4 and 2.6 makefiles are identical for the targets used
emake -f Makefile-2.4 CC=$(tc-getCC)
use doc && emake -C doc html
}

src_install() {
dolib.a libparapin.a
insopts -m0444; insinto /usr/include; doins parapin.h

dodoc README
if use doc; then
cd "${S}"/doc/${PN}
docinto html
dodoc *.html *.css *.png

cd "${S}"/examples
docinto examples
dodoc *.c
fi
}
40 changes: 40 additions & 0 deletions dev-embedded/parapin/parapin-1.5.1_beta1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit toolchain-funcs

DESCRIPTION="A parallel port pin programming library"
HOMEPAGE="http://parapin.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tgz"

LICENSE="LGPL-2.1"
IUSE="doc"
KEYWORDS="~amd64 ~x86"
SLOT="0"

DEPEND="doc? ( dev-tex/latex2html )"

S=${WORKDIR}/${P/_/-}

src_compile() {
# Note 2.4 and 2.6 makefiles are identical for the targets used
emake -f Makefile-2.4 CC=$(tc-getCC)
use doc && emake -C doc html
}

src_install() {
dolib.a libparapin.a
insopts -m0444; insinto /usr/include; doins parapin.h

dodoc README
if use doc; then
cd "${S}"/doc/${PN}
docinto html
dodoc *.html *.css *.png

cd "${S}"/examples
docinto examples
dodoc *.c
fi
}

0 comments on commit f676921

Please sign in to comment.