Skip to content

Commit

Permalink
dev-python/pytest-cov: enable py3.11
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 2, 2023
1 parent 7fcbad1 commit f67cb41
Show file tree
Hide file tree
Showing 2 changed files with 27 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
https://github.com/pytest-dev/pytest-cov/issues/566
https://github.com/pytest-dev/pytest-cov/pull/565

From 97483386bde4febe7ff48726f887cc6423d308b9 Mon Sep 17 00:00:00 2001
From: Chedi <[email protected]>
Date: Tue, 15 Nov 2022 11:18:31 +0100
Subject: [PATCH] disabling boxed test if version xdist newer than 2.5.0

--- a/tests/test_pytest_cov.py
+++ b/tests/test_pytest_cov.py
@@ -1555,7 +1555,8 @@ def test_foo():

SCRIPT_SIMPLE_RESULT = '4 * 100%'

-
+@pytest.mark.skipif('tuple(map(int, xdist.__version__.split("."))) >= (2, 5, 0)',
+ reason="--boxed option was removed in version 2.5.0")
@pytest.mark.skipif('sys.platform == "win32"')
def test_dist_boxed(testdir):
script = testdir.makepyfile(SCRIPT_SIMPLE)

8 changes: 6 additions & 2 deletions dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} pypy3 )
PYTHON_COMPAT=( python3_{8..11} pypy3 )

inherit distutils-r1

Expand Down Expand Up @@ -33,6 +33,10 @@ BDEPEND="
)
"

PATCHES=(
"${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
)

distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme
distutils_enable_tests pytest
Expand Down

0 comments on commit f67cb41

Please sign in to comment.