Skip to content

Commit

Permalink
app-i18n/fbterm: fix gcc6 build err
Browse files Browse the repository at this point in the history
thanks Peter Levine for providing patches

Gentoo-Bug: 594308

Package-Manager: portage-2.3.1
  • Loading branch information
dlan17 committed Sep 26, 2016
1 parent baba26b commit f732d20
Show file tree
Hide file tree
Showing 2 changed files with 129 additions and 0 deletions.
61 changes: 61 additions & 0 deletions app-i18n/fbterm/fbterm-1.7-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
inherit autotools-utils

DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
HOMEPAGE="https://fbterm.googlecode.com/"
SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="caps gpm video_cards_vesa"

RDEPEND="caps? ( sys-libs/libcap )
gpm? ( sys-libs/gpm )
video_cards_vesa? ( dev-libs/libx86 )
media-libs/fontconfig
media-libs/freetype:2"
DEPEND="${RDEPEND}
sys-libs/ncurses
virtual/pkgconfig"

AUTOTOOLS_IN_SOURCE_BUILD=1

DOCS=( AUTHORS NEWS README )

PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
)

src_configure() {
local myeconfargs=(
$(use_enable gpm)
$(use_enable video_cards_vesa vesa)
)
autotools-utils_src_configure
}

src_install() {
autotools-utils_src_install
$(type -P tic) -o "${ED}/usr/share/terminfo/" \
"${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
if use caps; then
setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
else
fperms u+s /usr/bin/fbterm
fi
}

pkg_postinst() {
einfo
einfo " ${PN} won't work with vga16fb. You have to use other native"
einfo " framebuffer drivers or vesa driver."
einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
einfo " To use ${PN}, ensure you are in video group."
einfo " To input CJK merge app-i18n/fbterm-ucimf"
einfo
}
68 changes: 68 additions & 0 deletions app-i18n/fbterm/files/fbterm-1.7-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
--- fbterm-1.7/src/lib/vterm_states.cpp.old 2016-09-24 00:44:29.981247206 -0400
+++ fbterm-1.7/src/lib/vterm_states.cpp 2016-09-24 00:48:40.463777924 -0400
@@ -39,14 +39,14 @@
{ 0x1B, 0, ESesc },
{ 0x7F, 0, ESkeep },
{ 0x9B, 0, ESsquare },
- { -1}
+ { (u16) -1}
};

const VTerm::Sequence VTerm::escape_sequences[] = {
{ 0, 0, ESnormal },

// ESnormal
- { -1 },
+ { (u16) -1 },

// ESesc
{ '[', &VTerm::clear_param, ESsquare },
@@ -65,7 +65,7 @@
{ '8', &VTerm::restore_cursor, ESnormal },
{ '>', &VTerm::keypad_numeric, ESnormal },
{ '=', &VTerm::keypad_application, ESnormal },
- { -1 },
+ { (u16) -1 },

// ESsquare
{ '[', 0, ESfunckey },
@@ -104,7 +104,7 @@
{ '`', &VTerm::cursor_position_col, ESnormal },
{ ']', &VTerm::linux_specific, ESnormal },
{ '}', &VTerm::fbterm_specific, ESnormal },
- { -1 },
+ { (u16) -1 },

// ESnonstd
{ '0' | ADDSAME(9), &VTerm::set_palette, ESkeep },
@@ -112,25 +112,25 @@
{ 'a' | ADDSAME(5), &VTerm::set_palette, ESkeep },
{ 'P', &VTerm::begin_set_palette, ESkeep },
{ 'R', &VTerm::reset_palette, ESnormal },
- { -1 },
+ { (u16) -1 },

// ESpercent
{ '@', &VTerm::clear_utf8, ESnormal },
{ 'G', &VTerm::set_utf8, ESnormal },
{ '8', &VTerm::set_utf8, ESnormal },
- { -1 },
+ { (u16) -1 },

// EScharset
{ '0', &VTerm::set_charset, ESnormal },
{ 'B', &VTerm::set_charset, ESnormal },
{ 'U', &VTerm::set_charset, ESnormal },
{ 'K', &VTerm::set_charset, ESnormal },
- { -1 },
+ { (u16) -1 },

// EShash
{ '8', &VTerm::screen_align, ESnormal },
- { -1 },
+ { (u16) -1 },

// ESfunckey
- { -1 },
+ { (u16) -1 },
};

0 comments on commit f732d20

Please sign in to comment.